Voice Quality - Gibberish and non-Connection problems

Discussion in '3CX Phone System - General' started by viperman1271, Sep 6, 2007.

  1. viperman1271

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    Hello all

    I was hoping that someone could help me with my installation. Please understand this when I say it, it is the installation or configuration of 3CX, not anything else. I have eliminated other possible reasons through testing and elimination. I do not have any VOIP gateway/VOIP router. I am using a Windows 2003 Server as my VOIP PBX server. I can receive calls (sometimes) but when anyone tries calling (mainly me) I get basically gibberish sounding speech that is barely comprehensible. When I go from an agent I get the next menu/extension go through and then a repeat of the original menu. Any ideas?
     
  2. ryan

    Joined:
    Aug 27, 2007
    Messages:
    35
    Likes Received:
    0
    Viperman, can you tell us the phones you are using and maybe some log entries (server status) that you see when having problems with the call?

    Also, do you have problems from internal extension -> extension or is the problem from external to internal?

    Cheers
    Ry
     
  3. viperman1271

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    I'm just using softphones for now. There is no problem with the internal communications for extension to extension. Also there is no problem with outgoing calls, only with incoming calls. Below are the logs.

    20:49:52.500 StratInOut::eek:nHangUp [CM104007] Call(1): Call from Ln:10000@InPhonex to 800 has been terminated by Ln:10000@InPhonex; cause: BYE; from IP:208.239.76.169
    20:49:44.375 CallLegImpl::eek:nConnected [CM103001] Call(3): Created audio channel for Ln:10000@InPhonex (208.239.76.169:33780) with Media Server (65.93.100.190:9004)
    20:49:44.312 CallConf::eek:nIncoming [CM103002] Call(3): Incoming call from 5198800739 (Ln:10000@InPhonex) to sip:4968701-b4gt1628t2664@10.0.5.66:5060
    20:49:44.046 CallLegImpl::eek:nConnected [CM103001] Call(2): Created audio channel for Ln:10000@InPhonex (208.239.76.169:33698) with Media Server (65.93.100.190:9002)
    20:49:44.015 CallConf::eek:nIncoming [CM103002] Call(2): Incoming call from 5198800739 (Ln:10000@InPhonex) to sip:4968701-b4gt1628t2664@10.0.5.66:5060
    20:49:43.796 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ln:10000@InPhonex (208.239.76.169:34054) with Media Server (65.93.100.190:9000)
    20:49:43.750 CallConf::eek:nIncoming [CM103002] Call(1): Incoming call from 5198800739 (Ln:10000@InPhonex) to sip:4968701-b4gt1628t2664@10.0.5.66:5060
    20:49:34.484 ListenConnect [CM114000] SL: connected mike-4fd2d2a2e5:0/PHPExtension_0 at [mike-4fd2d2a2e5:0]/PHPExtension_0
    20:49:23.140 ListenConnect [CM114000] SL: connected mike-4fd2d2a2e5:0/VoiceBoxManagerService at [mike-4fd2d2a2e5:0]/VoiceBoxManagerService
     
  4. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Can you be a little more specific as to your network conditions? What kind of banddwidth do you have and what codecs are you using? What softphone are you currently working with? How many users are in your VoIP network? This information might help troubleshooting a bit more.
     
  5. viperman1271

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    I've tested the conditions with both a DSL and a OS3 connection, so bandwidth is not a problem. I'm using ExpressTalk by NCH swift talk, for right now the users are limited to 1. I installed the VoIP PBX on a different server and all of a sudden I was getting crystal clear sound quality and then it regressed to the state of the other server with the terrible quality. I don't know about codecs.
     
  6. dyntech

    dyntech New Member

    Joined:
    Mar 28, 2007
    Messages:
    160
    Likes Received:
    0
    What about the health/performance of the server? Is it getting bogged down at certain times of the day? Are the drives fragmented? How much RAM does it have?

    You may the bandwidth but what about QoS?
     
  7. nmangaoang

    Joined:
    Jun 22, 2007
    Messages:
    35
    Likes Received:
    0
    Hi Viperman,

     
  8. viperman1271

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    The problem is not the softphone, the problem is with 3CX - nothing else. I have ruled everything else out, and it is 3CX. If you read my previous posts you would notice that the problem is not when the connection to the softphone is established, it is when the digital receptionist is engaged and the person on the other side of the phone call is listening to them. I have tried a direct connection to my VoIP provider's SIP server and the calls are clear. The problem resides with 3CX and cannot be anywhere else.
     

Share This Page