Voicemail hangs up on me :(

Discussion in '3CX Phone System - General' started by JPElectron, Apr 10, 2009.

Thread Status:
Not open for further replies.
  1. JPElectron

    Joined:
    Apr 10, 2009
    Messages:
    12
    Likes Received:
    0
    Fresh install of the latest version on Windows 2003 Web Edition - very slick, easy!
    Calling between my two extensions works great, calling the Digital Receptionist or Voicemail extensions results in nothing but being hung up on - don't get any instructions/announcement/login, can't press 9, just get "call ended" then fast busy signal untill I hang up.

    Tried changing Voicemail extension, no luck. Perhaps this is related to 127.0.0.1 IP seen in the log? but I could not find a way to set that to be the server's real IP. Server IP is static at 192.168.21.222

    From the log...

    15:51:03.265 [CM503008]: Call(1): Call is terminated
    15:51:03.250 [CM503008]: Call(1): Call is terminated
    15:51:00.437 [CM503007]: Call(1): Device joined: sip:999@127.0.0.1:40600;rinstance=4092171b238ef2e5
    15:51:00.421 [CM503007]: Call(1): Device joined: sip:101@192.168.21.100:5060
    15:51:00.421 [CM505001]: Ext.999: Device info: Device Identified: [Man: 3CX Ltd.;Mod: 3CX IVR;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX IVR] Transport: [sip:127.0.0.1:5060]
    15:51:00.406 [CM503002]: Call(1): Alerting sip:999@127.0.0.1:40600;rinstance=4092171b238ef2e5
    15:50:59.859 [CM503004]: Call(1): Calling: Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=4092171b238ef2e5]
    15:50:59.812 [CM503010]: Making route(s) to "Voice Mail"<sip:999@sip.test.jpelectron.com>
    15:50:59.781 [CM505001]: Ext.101: Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA941-5.1.8] Transport: [sip:192.168.21.222:5060]
    15:50:59.765 [CM503001]: Call(1): Incoming call from Ext.101 to "Voice Mail"<sip:999@sip.test.jpelectron.com>
    15:50:36.765 [CM504001]: Ext.101: new contact is registered. Contact(s): [sip:101@192.168.21.100:5060/101]
    15:50:17.843 [CM504008]: Fax Service: registered as sip:888@192.168.21.223:5060 with contact sip:888@192.168.21.223:5100;user=phone
    15:49:07.875 [CM504001]: Ext.101: new contact is registered. Contact(s): [sip:101@192.168.21.100:5060/101]
    15:46:54.812 [CM504001]: Ext.100: new contact is registered. Contact(s): [sip:100@192.168.21.107:5060/100]
    15:45:35.453 [CM504001]: Ext.800: new contact is registered. Contact(s): [sip:800@127.0.0.1:40600;rinstance=436fb0939442ed1a/800]
    15:45:35.453 [CM504001]: Ext.999: new contact is registered. Contact(s): [sip:999@127.0.0.1:40600;rinstance=4092171b238ef2e5/999]
    15:45:22.843 [CM504001]: Ext.*1: new contact is registered. Contact(s): [sip:*1@127.0.0.1:40000;rinstance=576096a3e00baf6b/*1]
    15:45:22.828 [CM504001]: Ext.*0: new contact is registered. Contact(s): [sip:*0@127.0.0.1:40000;rinstance=65ee9259e3eac59c/*0]
    15:45:19.125 [CM112000] Media Server is connected
    15:45:17.765 [CM504008]: Fax Service: registered as sip:888@192.168.21.223:5060 with contact sip:888@192.168.21.223:5100;user=phone
    15:45:16.640 [CM306002]: There is no valid STUN server specified! External IP can not be resolved.
    15:45:16.640 [CM306001]: Address of STUN server (stun2.3cx.com) could not be resolved!
    15:45:02.062 [CM306001]: Address of STUN server (stun.3cx.com) could not be resolved!
    15:44:52.656 IP(s) added:[192.168.21.222,192.168.21.223]
    15:44:42.812 [CM501006]: Default Local IP address: [192.168.21.222]
    15:44:42.593 [CM501002]: Version: 7.1.6292.0
    15:44:42.593 [CM501001]: Start 3CX PhoneSystem Call Manager
    15:44:42.593 [CM501007]: *** Started Calls Controller thread ***
    15:44:42.484 Unknown system [DBProvider] tries to connect!
    15:44:42.281 [CM501010]: License Info: Load Failed

    Thanks in advance for your help, willing to try anything to prove this works before purchase!
     
  2. JPElectron

    Joined:
    Apr 10, 2009
    Messages:
    12
    Likes Received:
    0
    ok, so apparently...

    My DNS config was not up to par - not only do you need an A record pointing the FQDN to the server running 3CX, but you need the SRV record as described in: http://www.3cx.com/support/sip-dns-configuration.html (note upd is the one that's needed, not tcp as pictured in the GUI)

    After that was fixed I would get a recorded error message when calling VM or DR, and learned that IVR runs from the site in IIS, and it did not like that I decided to run in on port 80 - under advanced I told it to run on 5484 too.

    Now everything is cool - just thought I'd leave this here incase anyone else runs across this same issue.
     
Thread Status:
Not open for further replies.