Voicemail light

Discussion in '3CX Phone System - General' started by ian.watts, Jan 15, 2015.

Thread Status:
Not open for further replies.
  1. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    3CX 12, Cisco SPA504 handsets.

    They complain that the voicemail light is on.. when it should not be. More so, we set the extensions to deliver to email and delete from the mbox.. so that indicator should be about never.
    When they check for voicemail, naturally they have none in the system.

    After vacation and I was back last week.. my own SPA has it lit on our own PBX.. no vm is there.
    So.. I fired up WireShark to see what's going on.

    First.. I set the test extension (307) voicemail to just drop onto the PBX.. no email.
    Used a softphone to dial *4+307.. left a voicemail.
    Light comes on.
    From the same softphone.. dialed voicemail, backed out and checked voicemail for 307.. light turns off.

    Indeed.. there is a NOTIFY message via SIP from the PBX to the handset per event:
    Left a voicemail:
    Messages-waiting: yes
    voice-message: 1/0

    Heard the voicemail:
    Messages-waiting: no
    voice-message: 0/1

    Deleted the voicemail:
    Messages-waiting: no
    voice-message: 0/0

    Okay.. fine. That's "how" the indicator works.. but how about when an extension is using the option to deliver voicemail via email and delete from the mbox? I expect there are no notifies sent to an endpoint.. apparently that is not the case.

    Left a voicemail:
    Messages-waiting: yes
    voice-message: 1/0

    And.. immediately after that notify (.000132 seconds on the trace..):
    Messages-waiting: no
    voice-message: 0/0

    On that test.. I did see the light "blip" on.
    Seems to be a bug? I have multiple clients on various revisions of 3CX.. but plenty on Cisco. Other than "mine" and all of theirs.. haven't heard too much otherwise.

    My guess thus far is that the Cisco may not be getting the second NOTIFY, cannot process it fast enough from the last, or sees an anomaly and drops. Whatever the case.. the result is the indicator stays on.. the only recourse is to reboot the phone. Changing the MWI setting to No will trigger the reboot anyway..

    Ideas? I'll be rigging more wireshark when I can.
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,133
    Likes Received:
    211
    I experienced this with My Yealinks when we first went live a couple years ago where 3cx was sending the "VOICEMAIL" message to the phone and then delivering the email, then sending the "NO MESSAGE" to the phone.
    The messages were arriving out of order.
    What fixed it?
    I do not know. It stopped happening.
    3cx said possibly network traffic.
    Any possibility to reboot your switches?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tsukraw

    tsukraw New Member

    Joined:
    Mar 9, 2012
    Messages:
    190
    Likes Received:
    7
    Take a look at my response to this question here.
    http://www.3cx.com/forums/message-waiting-light-issues-40751.html

    I know you do not have Yealink but i am guessing they have a similar setting.

    Also I just wanted to mention that 3CX V12.5 still functions the same that even with voice mail to email enabled the phone will get a NOTIFY of a voice mail then a split second later get a NOTIFY of no voice mail.

    Not sure the rime or reason that 3CX does this seems kind of silly but what i mentioned to the other post resolved it for us.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    Indeed interesting for the Yealink product.. but I'm not seeing a SUBSCRIBE/NOTIFY pair for the Cisco units.
    Upon the first REGISTER for an endpoint.. the NOTIFY is sent.
    I have a test phone now at a v9 install.. REGISTER is every 60 seconds.. no further NOTIFY messages until an endpoint reboot.. and another NOTIFY.

    There are no SUBSCRIBEs for these units.

    I have dug into more of the phone settings.. not finding other available options I can set.. 3CX keeps feeding NOTIFY on first registrations and voicemails left. If I could expire something, I could.
     
Thread Status:
Not open for further replies.