Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Voicemail sent to email that goes to text

Discussion in '3CX Phone System - General' started by nfletcher2, Jan 12, 2018.

Thread Status:
Not open for further replies.
  1. nfletcher2

    Joined:
    Oct 4, 2017
    Messages:
    46
    Likes Received:
    0
    Hello all!

    We have our Holiday and after hours calls route eventually to an extension that is setup to automatically go to voicemail. This extension then sends the voicemail to the email address setup in the extension and deletes the voicemail. This email address is actually a distro group on our email server that that goes to a few tech's email addresses and their cell phones. The cell phones are setup as cellnumber@att.txt.net (basically this), or whatever their provider has. So they do not get the voicemail (it strips it over text), but they get a text saying there is a voicemail. We us this for after hour emergencies.

    So recently we upgraded to 3CX 15 and this stopped working. The email addresses work, but no one ever gets the text. So I wanted to strip out the email server as the culprit so on the extension I added my cell phone to test directly as an email address (cellnumber@att.txt.net) to the extension and called and I never get the text. I can add my email though and it works. I even tried changing it to other users cells which are different carriers or even cellnumber@att.mms.net

    Thoughts? It is pretty important that we can notify our techs when someone leaves them a voicemail via text as they do not always see the emails.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    Are you testing (to the mobile number text to SMS service) by sending only the VM notification, or with the VM attached? If it with the VM attached, to a mobile number, there may be a size limitation by the receiving provider, which may cause it to fail

    Are you able to receive emails at the email address that 3CX sends as the originator? if so, you should see a failure message if the email is undeliverable.
     
  3. nfletcher2

    Joined:
    Oct 4, 2017
    Messages:
    46
    Likes Received:
    0
    I am sending the whole voicemail audio file because we need that voicemail to go to the users email as well. The way it works (historically) is we receive a text that lets us know there is a voicemail and then we go to the email that has it attached. It is more of a notification than anything.

    I thought that maybe it was a size limitation as well so I send a voicemail to my actual email. I then took the voicemail and attached it to a new email out of Outlook and copied the title and body and sent it and it successfully went through.

    I need to check the source mailbox, but I am thinking that there may not actually be a mailbox setup for it. We receive all other notifications so unless cell phone providers test whether that mailbox actually exist, I don't know that it would be the issue. I will look at that though.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    I use my mobile providers email to SMS service, just for VM notification. In my case, the originating 3CX email address I use is not valid (It's only there to let me know where the message originates), so I know my provider does not perform any sort of check. I suspect that yours is the same as that would involve way too many resources if the message was accepted. If it didn't go through, then, normally, your outgoing mail provider, would send the originator a message indicating as much.

    Have you tried temporarily using a gmail account, for testing?

    https://www.3cx.com/blog/docs/gmail-mail-server/
     
  5. nfletcher2

    Joined:
    Oct 4, 2017
    Messages:
    46
    Likes Received:
    0
    Okay, so I just got it working with our email server. I created the source email account and that did not fix it. I never received a bounce either. So I went into 3CX email settings and set it to actually authenticate and it actually started working. Not sure why anonymous was not working for those specific addresses, but it was not. Maybe something with our Exchange server. I will have to dig in. I just wanted to post in case anyone else runs into this.
     
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,552
    Likes Received:
    298
    You can setup Exchange to be anonymous - but by default - it allows internal email addresses only.

    To relay to external Domain you additionally need to execute the following powershell command. Be sure to change "relay" to whatever your connector is called.

    Get-ReceiveConnector “relay” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”

    I find it strange as you say you are using a distro group... so you are actually sending to an internal email address. But see if this works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    nfletcher2 likes this.
Thread Status:
Not open for further replies.