Solved Voicemail Silence Suppression Problem v.14-SP3

Discussion in '3CX Phone System - General' started by epeterson, Mar 7, 2017.

Thread Status:
Not open for further replies.
  1. epeterson

    Joined:
    Dec 17, 2015
    Messages:
    17
    Likes Received:
    0
    EDIT: I started a new thread with a more appropriate Title. It seems voicemails are getting 14 seconds clipped out of them starting at the 2 second mark and it has been repeatable 7 times.

    The link to the new thread is here: https://www.3cx.com/community/threads/voicemails-missing-14-seconds-of-audio-v-14-sp3.47969/

    EDIT #2: Solved in the above link. Antivirus on the 3CX server was the cause.


    We are getting voicemails that skip. The .wav file claims to be 1:19 duration but plays only 1:05 then closes. There is a noticeable click in the voicemail and the audio skips at that point. I am able to recreate the problem by calling and leaving a voicemail with periods of silence mixed in with the audio. The biggest problem is that this can cause the voicemail to play lots of silence and skip some of the audio.

    For example, call voicemail and leave message: (silently count 1,2,3,4,5,6) Seven, Eight, (silently 9,10,11,12,13,14) Fifteen, Sixteen, (silently 17,18,19, 20) Twenty-One, Twenty-Two (then hang up).

    The .wav file will report that it is 22 seconds long, but it will be about 6 seconds of silence followed by "Twenty-One, Twenty-Two" then the playback will stop with after about 9 seconds total play time.

    I have duplicated this problem by leaving voicemail from POTS and LAN based calls with the exact same outcome.

    How and where do I disable this silence suppression? I have attached a sample where I did exactly as described above (I renamed it to .txt).
     

    Attached Files:

    #1 epeterson, Mar 7, 2017
    Last edited: Mar 7, 2017
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,133
    Likes Received:
    211
    I just tested and recorded (silently count 1,2,3,4,5,6) Seven, Eight, (silently 9,10,11,12,13,14) Fifteen, Sixteen, (silently 17,18,19, 20) Twenty-One, Twenty-Two (then hang up). and played back (silently count 1,2,3,4,5,6) Seven, Eight, (silently 9,10,11,12,13,14) Fifteen, Sixteen, (silently 17,18,19, 20) Twenty-One, Twenty-Two (then hang up). - exactly how I recorded it.

    Settings- >Voicemail has an option of not saving messages less than x seconds - but that does not seem to be the issue you are experiencing. This is certainly not expected behavior.

    I am on v15 SP5 - but do not recall this issue anytime starting with v10.
    What are your machine specs?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #2 craigreilly, Mar 7, 2017
    Last edited: Mar 7, 2017
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    I'm on version 14 and find it works the way I would expect it to. There is no deletion of silence, and email alert shows the correct message length. Same result Craig had.
    Did this just begin? Any changes on your system, if it did? Most people don't tend to leave big gaps in their messages so if it does happen with others, it may go unnoticed.
     
  4. epeterson

    Joined:
    Dec 17, 2015
    Messages:
    17
    Likes Received:
    0
    I don't know if this is a new development or if it has always been like this (over a year that we've been using 3CX). This is the first time it has been reported to me. The "don't process voicemails under ___" was set at 1.5 seconds, I have changed it to 0.5 seconds but I'm pretty sure that's not the issue.

    3CX is the only thing running on a 2008-R2 guest, which is the only thing running on "Hyper-V 2012-R2" (Not SERVER 2012-R2, the "Less-than-'core'-Hypver-V-only," free VM host). The hardware is Dell PowerEdge R610 with 8GB RAM, dual Xeon E5520, and RAID-1. Essentially it's dedicated hardware, virtualization is for portability & disaster recovery.

    Can someone test this and see if you can duplicate my results?
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Just off the top of my head, I'm wondering if it has anything to do with the type/features of the audio card/audio software. I'm not certain if it is still the case, but a while back, server users that didn't have an audio card, couldn't use voicemail and the like. That may have been something related to an older 3CX version, and no longer applicable...but?
     
  6. epeterson

    Joined:
    Dec 17, 2015
    Messages:
    17
    Likes Received:
    0
    New development:
    A voicemail was just forwarded to me and it didn't sound like the person leaving the voicemail would be subject to silence suppression. Loud and clear but a click/glitch around the 2 second mark. The .wav file was truncated by 14 seconds.

    I started digging and all of the examples that have been forwarded to me and that I have generated are clipped around the 2 second mark and all are clipped by 14 seconds.

    I even just left a message for myself from my desk phone and counted out loud for 25 seconds.. The message was clipped at the 2 second mark and has 14 seconds clipped out of it.
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,514
    Likes Received:
    361
    for solution see this link
     
Thread Status:
Not open for further replies.