Voicemail SMTP broken in new release; how to fix?

Discussion in '3CX Phone System - General' started by Ryandc, Sep 27, 2007.

  1. Ryandc

    Joined:
    Aug 13, 2007
    Messages:
    70
    Likes Received:
    0
    Okay, here's what happened:
    I upgraded from 3.0 to 3.1 (whatever the current build is).
    Afterward, unbeknownst to me, the e-mail notification (of any sort, including vmail as attachment and notification-only) broke completely. I checked my SMTP server settings, and everything was configured correctly. I hadn't changed anything from my configuration in the 3.0 build, but it never hurts to check.

    Okay, so I figured that perhaps it was my SMTP provider being uncooperative, so I tried a different smtp e-mail account. Now, I've tried both Godaddy's (smtpout.secureserver.net) and Gmail's (smtp.gmail.com) with three correctly configured accounts, and all return the same error message in the logs. That error message is this:

    08:08:16.703|0580|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:43' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:08:28.781|0580|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:23' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:08:28.781|0580|.\TasksProcessor.cpp(787):CTaskSendNotify::SendNotify(), Maximal number of attempts (10) achieved for the 'from 27 Sep 2007 07:23' message ('201' extension). Sending canceled.
    08:13:16.734|0580|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:43' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:18:16.656|0584|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:43' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:23:16.921|0584|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:43' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:28:17.078|0580|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 07:43' message ('201' extension) has not been sent. Failed to connect to SMTP server smtpout.secureserver.net:25, response: '', error: Cannot connect to smtpout.secureserver.net:25, socket error 10022
    08:28:17.078|0580|.\TasksProcessor.cpp(787):CTaskSendNotify::SendNotify(), Maximal number of attempts (10) achieved for the 'from 27 Sep 2007 07:43' message ('201' extension). Sending canceled.
    09:01:29.218|057c|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 09:01, caller 231' message ('225' extension) has not been sent. Failed to connect to SMTP server smtpout.gmail.com:25, response: '', error: Cannot connect to smtpout.gmail.com:25, socket error 10022
    09:02:36.500|057c|.\TasksProcessor.cpp(771):CTaskSendNotify::SendNotify(), Error! Notification for the 'from 27 Sep 2007 09:02, caller 231' message ('225' extension) has not been sent. Failed to connect to SMTP server smtp.gmail.com:25, response: '', error: Cannot connect to smtp.gmail.com:25, socket error 10022

    That socket error 10022 shows up no matter what or how I have things configured. I've tried removing the :25 affix from the arguments supplied on the web configurator, but it seems as though 3cx appends it anyway. According to a brief google search, an error 10022 is the result of an invalid argument.

    This was working in build 3.0. What broke in 3.1? Any help, patches, or ideas would be greatly appreciated.
    --Ryan
     
  2. mfaster

    Joined:
    Jun 19, 2007
    Messages:
    21
    Likes Received:
    0
    Vmail SMTP notification broken

    I have the same problem
     
  3. RobLloyd

    RobLloyd Member

    Joined:
    Oct 13, 2006
    Messages:
    488
    Likes Received:
    0
    Try just using the smtp server and email to send from. When you have an account in there it seems to mess it up.

    I'm using Exchange and enter my MX record and an email address to have the mail come from:
    mail.blahblah.com and administrator@blahblah.com

    No username or password.
     
  4. mfaster

    Joined:
    Jun 19, 2007
    Messages:
    21
    Likes Received:
    0
    Clarification: I don't have the same problem

    All,

    I don't have the same problem. My SMTP issues turned out to be a problem with my network infrastructure and NOT 3cx!

    Mike
     

Share This Page