Voicemail system default prompt to press * for operator

Discussion in '3CX Phone System - General' started by Toddalex2000, Aug 26, 2017.

Thread Status:
Not open for further replies.
  1. Toddalex2000

    Joined:
    Aug 26, 2017
    Messages:
    9
    Likes Received:
    0
    Version 14
    We have an extension where we selected the system default option in the dropdown to "play this greeting for all profiles". You can find this under the voicemail tab for the ext. The system default prompt reads out fine but offers a * to reach an operator. If someone presses * it rings and then states "voicemail disabled for this ext".
    Where do i configure this * option for this ext?

    The ext is 954.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,585
    Likes Received:
    252
    Pressing * will send the call to whichever extension you have designated as the operator. It sounds as if that extension does not have voicemail enabled. You may want to consider forwarding the operator extension, if you do not use it for another function, to a digital receptionist, giving the caller some options, as to where their call will proceed next.
     
  3. Toddalex2000

    Joined:
    Aug 26, 2017
    Messages:
    9
    Likes Received:
    0
    Thanks for the reply. Where do i set this operator ext? Do i do this inside the extension in 3cx or by dialing into the VM of the extension? If inside the vm box what option?
     
  4. Toddalex2000

    Joined:
    Aug 26, 2017
    Messages:
    9
    Likes Received:
    0
    Also i thought operator extension was when you pressed 0.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,585
    Likes Received:
    252
    When you first set up 3CX you should have been asked to create an operator extension, or one was created for you. Traditionally this information is under Settings/PBX/General, but, may have moved in later versions. It is in the forwarding options, for this extension, that you would change where callers, that go to the operator, are directed.

    You can have extensions dialling zero, go to the operator extension, by setting the SIP ID of the operator extension to zero.

    A better term is Receptionist, rather than operator.
     
    #5 leejor, Aug 26, 2017
    Last edited: Aug 26, 2017
  6. Toddalex2000

    Joined:
    Aug 26, 2017
    Messages:
    9
    Likes Received:
    0
    I found the setting/pbx/general and its set to 100 which is what we point all unused DID's to.100 has no VM so i think i found the issue. So it seems my best bet is to record a greeting that doesn't offer the * or 0 option and only leave a message.

    Does that make sense?
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,585
    Likes Received:
    252
    Yes, if you don't want callers to dial *, then don't offer them the option.
     
  8. Toddalex2000

    Joined:
    Aug 26, 2017
    Messages:
    9
    Likes Received:
    0
    Will do. I wonder why 3cx is setup like this. It seems you should be able to setup the * or 0 option on a per mailbox basis rather than following a system setting. I know in Nortel or Avaya or Cisco you can define where those would go. If i want my 0 to go to my peer it would go there. SIP ID setting for the extension is another one i don't quite understand. If it's less than 3 characters the field turns red. know matter what its set to its seems to go to 100.
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,585
    Likes Received:
    252
    The option to send * or 0 , dialled from voicemail, to somewhere other than the operator extension, has been suggested in the Ideas forum a number of times. Have a read through then up-vote one, it may yet happen.

    https://www.3cx.com/blog/docs/dial-0-for-operator/
    Any dialplans, on the sets, must support single digit dialling.
     
Thread Status:
Not open for further replies.