Voicemail - This call could not be completed

Discussion in '3CX Phone System - General' started by adammason, Feb 20, 2012.

Thread Status:
Not open for further replies.
  1. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    Since moving server and backing up the database, restored fine and all is functional apart from when any phone calls the Voicemail. It says 'This call could not be completed' same with if a call to a devices rings off to voicemail produces same message.

    Any ideas?
     
  2. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Hi,

    Have you changed the web server? What server are you using? Check logs for any errors and post them here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    17:18:23.480 [CM503008]: Call(17): Call is terminated
    17:18:19.487 [CM503007]: Call(17): Device joined: sip:900@127.0.0.1:40600;rinstance=6d5de58eb98145b0
    17:18:19.481 [CM503007]: Call(17): Device joined: sip:106@86.162.230.###:1024
    17:18:19.231 [CM503025]: Call(17): Calling Ext:Ext.900@[Dev:sip:900@127.0.0.1:40600;rinstance=6d5de58eb98145b0]
    17:18:19.191 [CM503004]: Call(17): Route 1: Ext:Ext.900@[Dev:sip:900@127.0.0.1:40600;rinstance=6d5de58eb98145b0]
    17:18:19.183 [CM503001]: Call(17): Incoming call from Ext.106 to <sip:900@81.136.160.###>

    Could it be to do with the 127.0.0.1 ?

    Also I have used IIS instead of the other webserver..
     
  4. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    This is ok. 999 its a system extension registered on localhost. Are you using public IP for your extensions like 86.162.230.###?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    I changed it default voicemail to 900.. didnt want 999..

    Tried changing back made no difference

    Yes Public IP, as we are using extensions from a few locations, home and mobile..
     
  6. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    try to find location of 3CXIvrServer.log/3CXIvrServer.trace.log and post it here.
    To make things simpler, restart Digital receptionist service. Replicate problematic call. "zip" those files and attach archive to you post.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    Seems like this is the error

     
  8. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Your webserver is not running or http://localhost:5000/ivr is not accessible.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    Currently reinstalling IIS and 3cx.. will post update.. thanks for your help!
     
  10. adammason

    Joined:
    Dec 21, 2011
    Messages:
    14
    Likes Received:
    0
    Fixed.. Thanks again
     
  11. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Re-installation was not required. Unfortunately, we have not investigated this precedent here :(
    Anyway, I'm glad to know that problem was solved.
    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. nupton

    Joined:
    Oct 5, 2007
    Messages:
    26
    Likes Received:
    0
    We're having the same issue and I really don't want to reinstall. Using abyss, What is the not reinstalling fix?
     
  13. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Open Service Control Manager and restart (or start if it is not running) Abyss Web server.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. hostone

    Joined:
    Dec 20, 2010
    Messages:
    1
    Likes Received:
    0
    Every time I have seen this issue it's been related to the web browser. Usually the cause is .NET (updated .NET patches, etc).

    2 choices: check .NET etc and then restart IIS. Usually fixes the issue.

    or

    Switch to the Abyss Web Server (3CX) instead of IIS if you don't need the other IIS features of the product (like MyPhone chat client etc).

    I also notice the IIS option never seems to work on a desktop version of Windows.
     
  15. MrKoen

    Joined:
    Jul 3, 2009
    Messages:
    61
    Likes Received:
    0
    Genious! Encountered the same problem. This hinted for me that I just had changed the default port HTTP 5000 to port 80. Added HTTP 5000 back in IIS manager and it was up and running again. Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. bsloan9858

    Joined:
    Feb 1, 2012
    Messages:
    8
    Likes Received:
    0
    3CX support, I'm having the same exact issues but with using the built in web server on v14SP3. I posted my issue in the forum but no one has yet replied. Can you please help!
     
Thread Status:
Not open for further replies.