VoIP-gateway in PSTN <-> SIP mode / incoming from PSTN

Discussion in '3CX Phone System - General' started by VladislavA, Jun 14, 2007.

Thread Status:
Not open for further replies.
  1. VladislavA

    Joined:
    Jun 9, 2007
    Messages:
    30
    Likes Received:
    0
    Recently I tried to use the D-Link DVG-6004S as a VoIP-gateway in PSTN <-> SIP mode.

    I found that internal communications (SIP-phone <-> SIP-phone) is fine but PSTN <->Gateway <->3CXPhoneSystem<->SIP-phone communication is impossible.

    Firstly, I tried troubleshooting PSTN incoming call (PSTN -> Gateway ->3CX_Phone_System -> SIP_Phone). During call initiation 3CX generated server status message
     
  2. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    PBX just can not associate received SIP INVITE with any known entity. Create PSTN gateway with line that has internal number 10000. And read the manual.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. VladislavA

    Joined:
    Jun 9, 2007
    Messages:
    30
    Likes Received:
    0
    Yeah, I already have defined "PSTN line" and "VoIP Gateway Configuration".

    Result is the same for default Advanced options and corrected Advanced options.

    I tried two modes (with Hotline and w/o Hotline) with the same result. Then I decided that problem in 3CX.

    Here are the settings for Hotline mode (VoIP gateway web interface):
    * The Telephony settings page.
    Line: 1
    Enable: (checked)
    Type: FXO
    Hot Line: (checked)
    Hot Line No.: 100

    All other settings are by default.

    Here are the settings for "w/o Hotline" mode (VoIP gateway web interface):
    * The Telephony settings page.
    Line: 1
    Enable: (checked)
    Type: FXO
    Hot Line: (unchecked)
    Hot Line No.: (empty)

    All other settings are by default.

    In the "w/o Hotline" mode I entered "100" on the deskphone after VoIP gateway voice message.
     
  5. VladislavA

    Joined:
    Jun 9, 2007
    Messages:
    30
    Likes Received:
    0
    One man from the forums.d-link.ru forum told me about using D-Link WAN Ethernet interface instead of D-Link LAN interfaces. (Note - I don
     
Thread Status:
Not open for further replies.