VOIP GATEWAY SETTINGS

Discussion in '3CX Phone System - General' started by SaturnTech, Mar 24, 2010.

Thread Status:
Not open for further replies.
  1. SaturnTech

    Joined:
    Nov 3, 2009
    Messages:
    11
    Likes Received:
    0
    I'm using CallCentric as a provider and configured VOIP through the template, etc. It appears to use extension 10000 within the system to register with CallCentric however I have 3 DIDs. No masks, just separate numbers. I may want to have a different inbound route for each of the 3 DID numbers when a call comes in. In the SourceID tab I have the "Source identification by DID" selected and in the SIP field containing DID numbers I have selected "To: UserPart" with all of my DIDs listed in the box below. I can clearly see in the server activity log a line that appears to define the 3cx awareness of the dialed number as shown below.

    16:59:06.295 [CM503012]: Inbound out-of-office hours rule (unnamed) for 10000 forwards to DN:38
    16:59:06.295 Looking for inbound target: called=15200000000; caller=18880000000


    If my belief is true, why is the system defaulting to what is defined for the 1777xxxxxxx number that is shown representing CallCentric when it comes to routing the call? I have different rules for each DID but they are being ignored based on processing a rule for extension 10000 (CallCentric registration extension). I mean, I could live with routing everything to one location but if the software supports DID routing, I'd like to give it a try.

    What might I be doing wrong?
     
  2. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    I think you have it set up incorrectly.

    Undo the changes you made with the extra DIDs.

    The way 3cx works is you have a main DID/BTN with a Voip provider. And a default inbound rule for it. If you dont change it then all incoming calls on that provider follow the main rule. To make rules for different numbers on that provider (with no masks) do the following.

    1. Edit the provider. go to the DID tab at the end and add each DID one at a time (put it in the box above the Add button then click the Add button). This will now allow you to make inbound rules.

    Go to your Inbound rules and create a new rule for each DID. Put the DID in the DID/DDI number/mask with no spaces or dashes (e.g. 555111222) then set the rules for office hours and/or after hours as you wish.

    Let me know if you still have problems.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SaturnTech

    Joined:
    Nov 3, 2009
    Messages:
    11
    Likes Received:
    0
    Interesting...I think this is the way I had it set up originally and no dice. Why does it appear you can control inbound routing through the VOIP settings and the Inbound rules? I'm changing it back the way it was and will post back shortly.
     
Thread Status:
Not open for further replies.