Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Voip Phone don't connect with server using external network

Discussion in '3CX Phone System - General' started by FGMLVoip, Mar 24, 2009.

Thread Status:
Not open for further replies.
  1. FGMLVoip

    Joined:
    Mar 17, 2009
    Messages:
    3
    Likes Received:
    0
    Hello, I am not able connect to the 3CX server through the Internet. Only through the local network.

    I have done the tests with two open networks, with the firewall off.

    I get the public IP of the 3CX server connection and try to use the tunnel to make the connection, but he can not.

    If I try to use the tunnel on the internal network, it works normally, but never succeeded in the external network connection. Recalling that there is no firewall enabled, and the two networks are open to the test.

    Should not connect?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. almiller1963

    Joined:
    Mar 5, 2009
    Messages:
    8
    Likes Received:
    0
    If you are using a router you need to have port forwarding setup to forward the required ports to your 3cx box.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. FGMLVoip

    Joined:
    Mar 17, 2009
    Messages:
    3
    Likes Received:
    0
    Hi, I use an ADSL modem Dlink DLS-500B configured as a bridge, and a Linksys WRT54G router to establish the PPPoE connection.

    The tunnel's listening port is 5090 and is open for both UDP, TCP on foot.

    I did the tests with the firewall off. Both the external network (internet), as the network of the 3CX server.

    Considering that all firewalls were off, I do not need to create the port forwarding, since there are no restrictions on access to any port or protocol of communication.

    Furthermore, the router making the PPPoE connection is enabled with the DMZ to the IP of the server. Thus, there is no restriction on access. It is as if the server, was in fact in public. Correct?

    The strange thing is that even on the internal network, if I set the Voip Phone to get the external IP or domain, you can not establish the tunnel.

    I do not know what to do more to resolve this.

    Thank's;
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,071
    Likes Received:
    323
    I'm assuming that you are using the 3CX VoIP client softphone. Can you connect via the softphone from "outside" NOT using the tunnel settings? There are several set-ups for the softphone that you can pre-configure. I've had problems using the tunnel settings but no problem connecting remotely using the other "out of the office" settings. I don't have it in front of me right now and it has been several weeks since i worked on it so i can't recall all the terms for the settings. I had sort of given up getting the tunnel to work as I ran out of time to spend on it and it worked the other way.
     
Thread Status:
Not open for further replies.