Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

VOIP provider Authorization code is different from User ID

Discussion in '3CX Phone System - General' started by doronsaar, Aug 26, 2010.

Thread Status:
Not open for further replies.
  1. doronsaar

    Joined:
    Aug 26, 2010
    Messages:
    3
    Likes Received:
    0
    So it's impossible to set it up as a provider in 3CX phone system.

    The voip line works perfectly without any problems on x-lite client program, but no way on 3cx.

    Any Ideas?
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    I see you have given up quite easily. Nothing is impossible, 3CX is very flexible and tries to limit nothing. With that in mind and considering your answer is not very long ( please read forum rules on posting). Please see attached screenshot that should relate to your configuration settings.

    If this is not what your looking for please be more clear and I will assist you further.
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. doronsaar

    Joined:
    Aug 26, 2010
    Messages:
    3
    Likes Received:
    0
    Thank you,

    I put the authentication ID I have on this outbound SIP field "To: User Part".

    I still get on the server activity log "registration failed .. Cause: 401 Unauthorized."
    When I put the authentication ID in the Authentication ID text box on the "account details", and the phone number in the "To: User Part" sip field, I get the error: "Cause: 404 Not found"

    More info:

    When connecting from a MP202 SIP Adapter, the settings look like this:



    Is there any other place I might be able to put this Authentication ID in?
     

    Attached Files:

  4. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    HI,

    It seems like you are failing at registration stage, therefore calling becomes useless.

    In the VOIP provider settings:

    Authentication ID = CB9823...
    Passowrd: = authenticaion password

    and try and re register.

    At this point if you still can get it to work, I will have to divert you to open up a support ticket at http://support.3cx.com and we will try and set up the voip provider for you and test it ourselves.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. doronsaar

    Joined:
    Aug 26, 2010
    Messages:
    3
    Likes Received:
    0
    I've obviously tried that already.

    3CX simply doesn't have this simple feature of putting a seperate Authentication ID different from the phone number.

    Eventually I had no choice but to install the competitor: Axon.
    http://www.nch.com.au/pbx/index.html

    In Axon there is no such problem, and the registration succeeded.
     
Thread Status:
Not open for further replies.