Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

VoIP Provider: BT Broadband Talk

Discussion in 'Windows' started by jedarlington, Aug 20, 2009.

Thread Status:
Not open for further replies.
  1. jedarlington

    Joined:
    Aug 20, 2009
    Messages:
    1
    Likes Received:
    0
    I am trying to setup a VoIP provider that is not listed in the supported provider templates - BT Broadband Talk, a UK VoIP service.

    I have managed to gather some details on BT Broadband Talk VoIP.

    SIP Server: btsip.bt.com
    SIP Server Port: 5060
    Outbound Proxy: sp2.btsip.bt.net
    Outbound Port: 5060

    Has anyone got BT Broadband Talk setup and working correctly?

    Any help or advice much appreciated.
     
  2. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    So long as they are using SIP standards there is no reason why it shouldn't work.

    Perform these steps to troubleshoot;

    1. Verify your Username, Password, and CID are correct in the provider. You can check to make sure its not a firewall issue by using the VoIP client.
    2. Remove the outbound proxy and then check weather you have green light or not.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. RqtMan

    Joined:
    Sep 18, 2009
    Messages:
    2
    Likes Received:
    0
    Hello,

    I have this configuration working. It is necessary to first get your 3CX system to think it is talking directly to the btsip.bt.com address but actually point it to one of the proxy ip addresses for sp2.btsip.bt.com.

    First do an nslookup on sp2.btsip.bt.net and note one of the IP addresses.

    Next add this line to the windows host file, e.g. c:\windows\system32\drivers\etc\host

    xxx.xxx.xxx.xxx btsip.bt.com

    where xxx etc is one of the sp2.btsip.bt.net ip addresses.

    When defining BBT as a SIP tunk you simply need to put btsip.bt.com as your SIP server / hostname, no proxy server required.

    Finally, I recommend setting your BT Home Hub up to register as an extension(s) on your 3CX pbx giving you the ability to connect up a number of DECT handsets as extensions on the 3CX system.


    Good Luck
     
  4. webby

    Joined:
    Oct 20, 2009
    Messages:
    25
    Likes Received:
    0
    Well done getting this to work.

    I have tried taking the steps you suggested but it still won't work. However I am not using (nor do i have) a BT Home Hub.
    I am using a Linksys Router.

    I think it is disgusting of BT to sell a service - the operator said it would be no problem to use my own IP phone - and not supply the settings!

    Next i wanted a SIP trunk which they told me would be available in the next couple weeks and that it would connect straight in to my phone system - how is it going to do that if they won't give me the settings?!!!!!

    *#@##** #*@%'#
     
  5. RqtMan

    Joined:
    Sep 18, 2009
    Messages:
    2
    Likes Received:
    0
    Did you get the settings in the end?

    BT Sip settings can be found by following this link, http://www.bt.com/bbt

    Login using your assigned username and password, click "configure hub/router".

    right click the red "Configure" button and "copy shortcut".

    Settings can be found in the link when pasted into Notepad.
     
  6. alanvsmith

    Joined:
    Aug 16, 2010
    Messages:
    1
    Likes Received:
    0

    Anyone know how to get BBT working on 3CX in an android? I use a Draytek 2820Vn and have the settings working fine on that, also a Grandstream GXV3000 works. I've tried several combinations for BBT on the Android, but can't get it to register at all. Sipgate is working fine.
     
Thread Status:
Not open for further replies.