VOIP provider & SIP phone registration questions

Discussion in '3CX Phone System - General' started by daniboa, Feb 24, 2007.

  1. daniboa

    Joined:
    Feb 22, 2007
    Messages:
    7
    Likes Received:
    0
    I'm testing this PBX from a few days and I'm finding some problems like:

    - Sometime during the clientregs can't register, reason=service unavailable. After some minutes (but 20!!!) it's registering correctly. This is happening 8/10 times a day.
    - Sometime even if the server is correctly registered to the provider I can't receive incoming calls
    - If I call my number with a cellular phone I can't receive the call and on the cellular I can't hear any tone sound.

    This is for now.....Anybody else with same problems? Any tip?

    I hope it will work everything better, I think it's a great PBX, simple to configure and with interesting functions.
     
  2. Anonymous

    Anonymous Guest

    Re: Unstable

    Sometime during the clientregs can't register, reason=service unavailable. After some minutes (but 20!!!) it's registering correctly. This is happening 8/10 times a day.
    Intersting, I do not have that problem. Check your SIP phone and see if it de-registers after an x period of time. YOu can set up your phone to register faster, depending on the phone.

    If I call my number with a cellular phone I can't receive the call and on the cellular I can't hear any tone sound.
    Ehhhh. if you do not hear anything on your cellular and that is the call initiator than you might not have Cellular access. YOu should always hear atleast a dial tone or ring tone on the call initiator.

    Sometime even if the server is correctly registered to the provider I can't receive incoming calls
    What does that mean? you do not get any calls to the IPBX? Is your gateway configured to forward the calls to your IPBX after xyz amount of time?
     
  3. daniboa

    Joined:
    Feb 22, 2007
    Messages:
    7
    Likes Received:
    0
    It means this, I have my wonderfull Grandstream GXP-2000 phone, I always use it till now and from one year with a voip provider with 3 phone numbers. I'm using it for work as it's in my office and I would like to share this numbers also with other 3 collegue using soft phones on their computers. So I installed your PBX and I configured it correctly, I opened all the necessary ports on my router's firewall and also I configured the NAT linking the necessary ports to the computer server where the PBX is installed.
    So these are the logs:
    - ServRegs::eek:nAdd: Registered: Ext.101 (and the same for 102-103-104)
    - 14:58:25.078 ClientRegs::eek:nSuccess: Registration of sip:??????646@voip.eutelia.it:5060 is successful
    14:58:24.968 ClientRegs::eek:nSuccess: Registration of sip:??????404@voip.eutelia.it:5060 is successful
    14:58:24.906 ClientRegs::eek:nSuccess: Registration of sip:??????249@voip.eutelia.it:5060 is successful
    - 14:58:24.218 StunClient::process: STUN resolved external IP=??.???.???.??? by server 80.239.235.209
    14:58:24.015 StunClient::process: Send initial STUN request to 80.239.235.209

    So everything seems to be perfectly OK and correctly registered.
    I'm able to make external calls from all the extensions. I'm able to make calls between the extensions and to the voice mail number (999) and to the Digital Receptionist (802 and 803).
    When I'm trying to call my 3 voip numbers with a normal phone sometime it's working, the digital receptionist answer correctly and it's diverting the number to desired extension. Sometime when I'm calling this 3 numbers with the normal phone, anything it's working, I'm earing any sound from the phone that I'm calling with, any tone, the log show everything it's ok and registered but it's not showing any incoming call(????????). And I didn't touch anything from the before working configuration.

    That's all. I hope it's clear. Any suggestion?
     
  4. costellazione

    Joined:
    Mar 31, 2007
    Messages:
    8
    Likes Received:
    0
    skypho voip account with 3cx

    Hello Daniboa,
    I read your post and understood you found a way to make/receive call using skypho voip account.
    could you please post the successful configuration skypho voip account with 3cx?

    I can do call but I can't receive it.
    Eutelia prompt voice message say: "the number is momentany not avalaible"

    Coul you help me?

    (if you are Italian can answer directly in italian)

    Thanks for your help!
    Costellazione
     
  5. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,677
    Likes Received:
    17
    VOIP provider

    Thank you for your post.

    First of all please mention what VOIP provider and VOIP phones you are using. I am suspecting that not all of them are supported. If registration with your VOIP provider fails it could very well be that your VOIP provider is not supported by us yet.

    From your second post it seems that the main problem is that not all incoming calls are received at 3CX Phone System?

    Please post us the server status log of an incoming call that fails. This would help us identify where the problem lies. You have posted a server status log with a successfull registration which will not help us identify the issue you are having.
     
  6. costellazione

    Joined:
    Mar 31, 2007
    Messages:
    8
    Likes Received:
    0
    Hello Nick and thank you for your immediate replay!

    I'm using "Skypho" provider (Eutelia Group) and your softphone 3cx Phone.

    If you are referring to server status here a copy:
    10:29:36.296 ClientRegs::eek:nSuccess Registration of sip:09611916128@83.211.227.21 is successful
    10:29:35.828 ExtLine::Register_ Send registration for "09611916128"<sip:09611916128@83.211.227.21>
    10:29:35.828 ExtLine::Register_ Use External IP for device line registration DN='10000' device='09611916128'
    10:29:35.531 StunClient::process STUN resolved external IP=62.123.212.179:62132 by server 83.211.227.26
    10:09:35.921 ClientRegs::eek:nSuccess Registration of sip:09611916128@83.211.227.21 is successful
    10:09:35.531 ExtLine::Register_ Send registration for "09611916128"<sip:09611916128@83.211.227.21>
    10:09:35.531 ExtLine::Register_ Use External IP for device line registration DN='10000' device='09611916128'
    10:09:35.218 StunClient::process STUN resolved external IP=62.123.212.179:62123 by server 83.211.227.26
    09:49:35.781 ClientRegs::eek:nSuccess Registration of sip:09611916128@83.211.227.21 is successful
    09:49:35.312 ExtLine::Register_ Send registration for "09611916128"<sip:09611916128@83.211.227.21>
    09:49:35.312 ExtLine::Register_ Use External IP for device line registration DN='10000' device='09611916128'
    09:49:35.015 StunClient::process STUN resolved external IP=62.123.212.179:62120 by server 83.211.227.26
    09:29:35.468 ClientRegs::eek:nSuccess Registration of sip:09611916128@83.211.227.21 is successful


    And this is 3CX PHONE log:
    -------------------------------------------
    11.56.52,937: R: 192.168.178.100:5060
    SIP/2.0 200 OK
    Via: SIP/2.0/UDP 192.168.178.100:4479;branch=z9hG4bK004aeafba4dedb11a16d00138f987c0a
    Contact: <sip:100@192.168.178.100:4479>;expires=900
    To: <sip:100@192.168.178.100>;tag=cc7fd232
    From: "test"<sip:100@192.168.178.100>;tag=2162
    Call-ID: 80B351FB-A4DE-DB11-A16C-00138F987C0A@192.168.178.100
    CSeq: 2 REGISTER
    User-Agent: 3CXPhoneSystem
    Content-Length: 0


    The problem is when I receive a failed call not changement is made in server status.
    However I can do all calls I want and, I think, this means account number is right working.

    While I wait for a your replay have you a nice day.

    Costellazione
     
  7. costellazione

    Joined:
    Mar 31, 2007
    Messages:
    8
    Likes Received:
    0
    Hello Nick,
    after many hours I get it working!

    So I can make and receive calls now, but after an hang up call the server never disconnect extension. I can read a message: Status: Connected: (10000) with yellow ball.

    Also I notice the page http://localhost:5481/status.php never end loading... (on the status bar I'm reading "Waiting for localhost..)



    Thank you in advance if you would like help me.

    Costellazione
    from Italy
     

Share This Page