Voip Provider works with US calls ONLY

Discussion in '3CX Phone System - General' started by lkaegi, Aug 23, 2011.

Thread Status:
Not open for further replies.
  1. lkaegi

    Joined:
    Aug 23, 2011
    Messages:
    4
    Likes Received:
    0
    Hello,

    I'm tryin to configure overvoip.net Voip Provider on my 3cx phone system. I configured the provider with the Generic Voip Provider wizard. When I dial an outside number I have a dial tone, the IVR comes on, and everything seems to work properly. When I dial a US number I'm connected through with out any problems, sound quality is perfect. When I dial a European number, the IVR comes on, tells me the call is being connected, but then tells me "All circuits are busy, pleae try your call later, error 4011". I'm puzzled, initial connection with the Voip Provider has no problems, I can make calls to the US with no problems, which would mean the configuration is ok. Any ideas on what this error means ??? I really need to solve this so please help !!!

    Leandro.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    My first guess (and that's all it is until you post some 3CX logs showing the attempted calls), is that you need to "adjust" your outbound rules to accommodate both the numbers you are dialling and what your VoIP provider wants to see for an overseas calls.

    I'm also not clear as to why there is an IVR involved in an outbound call.
     
  3. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    What is your outbound rule for international calls ?
    Are you dialing 004420... or +4420... or 0114420... for calling a London number for example ? What your provider expects as international dialing prefix ?

    By the way, how you dial local (national) numbers ?

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    most voip providers in the US want to see the 011 number when dialed. it would be best to see a log of the call being made.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. lkaegi

    Joined:
    Aug 23, 2011
    Messages:
    4
    Likes Received:
    0
    Here's a log of the two calls being made.

    The 17862641252 is the us number no problems whit this call

    The 34942082456 is the European number. This call wont connect.

    My Voip Provider has an IVR which tells your credit everytime you make a call that why I mention it.



    12:00:21.750 Currently active calls - 1: [11]
    12:00:19.875 [CM503007]: Call(11): Device joined: sip:099879845230@sip01.us.overvoip.net:5060
    12:00:19.875 [CM503007]: Call(11): Device joined: sip:22@192.168.1.12:5060
    12:00:19.875 [CM505003]: Provider:[TalkFree] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:099879845230@190.92.54.190:5060]
    12:00:19.859 [CM503002]: Call(11): Alerting sip:099879845230@sip01.us.overvoip.net:5060
    12:00:18.859 [CM503025]: Call(11): Calling VoIPline:34942082456@(Ln.10000@TalkFree)@[Dev:sip:099879845230@sip01.us.overvoip.net:5060]
    12:00:18.640 [CM503004]: Call(11): Route 1: VoIPline:34942082456@(Ln.10000@TalkFree)@[Dev:sip:099879845230@sip01.us.overvoip.net:5060]
    12:00:18.640 [CM503010]: Making route(s) to <sip:34942082456@192.168.1.15>
    12:00:18.640 [CM505001]: Ext.22: Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/PAP2-3.1.9(LSc)] PBX contact: [sip:22@192.168.1.15:5060]
    12:00:18.640 [CM503001]: Call(11): Incoming call from Ext.22 to <sip:34942082456@192.168.1.15>
    12:00:04.484 [CM503008]: Call(10): Call is terminated
    11:59:49.750 Currently active calls - 1: [10]
    11:59:44.234 [CM503007]: Call(10): Device joined: sip:099879845230@sip01.us.overvoip.net:5060
    11:59:44.234 [CM503007]: Call(10): Device joined: sip:22@192.168.1.12:5060
    11:59:44.234 [CM505003]: Provider:[TalkFree] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:099879845230@190.92.54.190:5060]
    11:59:44.234 [CM503002]: Call(10): Alerting sip:099879845230@sip01.us.overvoip.net:5060
    11:59:43.421 [CM503025]: Call(10): Calling VoIPline:17862641252@(Ln.10000@TalkFree)@[Dev:sip:099879845230@sip01.us.overvoip.net:5060]
    11:59:43.250 [CM503004]: Call(10): Route 1: VoIPline:17862641252@(Ln.10000@TalkFree)@[Dev:sip:099879845230@sip01.us.overvoip.net:5060]
    11:59:43.250 [CM503010]: Making route(s) to <sip:17862641252@192.168.1.15>
    11:59:43.250 [CM505001]: Ext.22: Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/PAP2-3.1.9(LSc)] PBX contact: [sip:22@192.168.1.15:5060]

    If you need more info please let me know.

    Leandro.
     
  6. lkaegi

    Joined:
    Aug 23, 2011
    Messages:
    4
    Likes Received:
    0
    My outbound rule is that if you dial an 11 digit nuumber it goes to the Voip provider, else it an internal call. Also my provider judges where the call goes by putting the country code. Example. 1 is the us 34 is Spain.

    Leandro.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    If your provider is US based (which it looks like). then you may be confusing the "1" at the beginning of a North American number as the country code and not a long distance access code, which it may be. You may need to prefix your overseas numbers with "011", the North American international prefix. You should contact your provider to confirm how they want to receive an international number.

    3CX outbound rules can be set up so that a prefix can be added automatically.
     
  8. lkaegi

    Joined:
    Aug 23, 2011
    Messages:
    4
    Likes Received:
    0
    Ok,

    So I tried prepending "011" and still nothing. Im almost sure the problem is the Voip Provider is thinking the dialed number is wrong since I tried dialing wrong numbers and I get the same response. Any ideas on what format non us numbers should have???
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    I would contact your provider for more information. They should have supplied y0u with the required number formats.
    It may also be that they do not allow international calls unless you specificity ask for that option to be enabled. Some providers do this to protect customers from huge "surprise" bills
     
Thread Status:
Not open for further replies.