Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

VoIP Trunk with Wateen

Discussion in '3CX Phone System - General' started by sadnblueish, Jan 21, 2009.

Thread Status:
Not open for further replies.
  1. sadnblueish

    Joined:
    Jan 21, 2009
    Messages:
    1
    Likes Received:
    0
    Hi,

    My Service Provider (Wateen) provides SIP connections. I can use my SIP phone through any softphone (e.g., Xlite). When I try to configure 3CX to use Wateen as outbound call Provider I get authentication problem. Wateen requires an "authorized username" field with the syntax sip_number@wateen.net. Wateen is also using a proxy host with port 9060. When I configure 3CX without much customization, I get following errors when I dial an outbound number from my local extension:


    16:42:01.780 [CM503008]: Call(67): Call is terminated

    16:42:01.749 [CM503015]: Call(67): Attempt to reach <sip:03004007776@wateen.net> failed. Reason: Forbidden

    16:42:01.749 [CM503003]: Call(67): Call to sip:03004007776@wateen.net:9060 has failed; Cause: 403 Forbidden; from IP:58.27.240.22:9060

    16:42:01.546 [MS210006] C:67.2:Offer provided. Connection(by pass mode): 192.168.0.249:8334(8335)

    16:42:01.515 [CM503004]: Call(67): Calling: VoIPline:03004007776@(Ln.@wateen)@[Dev:sip:0518230867%40wateen.net@wateen.net:9060]

    16:42:01.452 [CM503010]: Making route(s) to <sip:03004007776@wateen.net>

    16:42:01.452 [MS210000] C:67.1:Offer received. RTP connection: 192.168.0.249:8334(8335)

    16:42:01.452 Remote SDP is set for legC:67.1

    16:42:01.452 [CM505001]: Ext.6001: Device info: Device Identified: [Man: Counterpath;Mod: eyeBeam;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, recvonly] UserAgent: [eyeBeam release 3007n stamp 17816] Transport: [sip:192.168.0.242:9060]

    16:42:01.405 [CM503001]: Call(67): Incoming call from Ext.6001 to <sip:03004007776@wateen.net>

    16:42:01.358 [CM500002]: Info on incoming INVITE:

    INVITE sip:03004007776@wateen.net SIP/2.0

    Via: SIP/2.0/UDP 192.168.0.249:8235;branch=z9hG4bK-d87543-666912821-1--d87543-;rport=8235

    Max-Forwards: 70

    Contact: <sip:6001@192.168.0.249:8235>

    To: <sip:03004007776@wateen.net>

    From: "6001"<sip:6001@wateen.net>;tag=8b5b0200

    Call-ID: 1220b658c50fd302

    CSeq: 2 INVITE

    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO

    Proxy-Authorization: Digest username="6001",realm="3CXPhoneSystem",nonce="12877011721:cc47b1ab75b040c801e2f967205ee18a",uri="sip:03004007776@wateen.net",response="ca428769cbebe3c478eb712f18c77eb9",algorithm=MD5

    User-Agent: eyeBeam release 3007n stamp 17816

    Content-Length: 0



    Help will be highly appreciated.
     
  2. William400

    William400 Well-Known Member

    Joined:
    Aug 21, 2006
    Messages:
    1,005
    Likes Received:
    0
    Hi

    You will need to do some playing around with the VOIP Provider > Outbound parameter to fix this.

    Can you tell us where exactly Wateen need the user id? If they need it in the From: User Part, then set the ;

    From: User Part --> AuthID . Then click apply and ok.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.