Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

VoxBone trunk - anyone got this working?

Discussion in '3CX Phone System - General' started by cejota3, Aug 17, 2011.

Thread Status:
Not open for further replies.
  1. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Hello, I've search the forums and there are a _few_ posts with questions about geting a VoxBone SIP number working with 3CX. Unfortunately, few of those posts have any useful follow-ups, and none of them (as far as I can tell) have someone that says, "Yes, I got it working by doing such and such!"

    I use VoxBone very successfully with some other non-3CX systems I have and would like to start having some of their DID's go to our 3CX system. VoxBone is an inbound only SIP provider. I've tried setting up a "Generic VoIP Provider" and a "Generic VoIP Trunk" to no avail. I've set up Generic VoIP providers before, so I have some experience with this.

    I'm sure things are configured correctly from the VoxBone side of things. My very strong suspicions are that the "Source ID" stuff is not quite right (and thus, 3CX is rejecting the call attempt, i.e. rejecting the INVITE). I've been playing around with the "Source ID" criteria, but again, to no avail.

    What would help would be some way, a log or something, that would show if an attempt to place a call into 3CX was made but that it rejected it due to not matching any Source ID info. Such attempts do not show up in the "Server Activity Log" (in my experience thus far).

    Any help would be appreciated! Thanks, C.J.
     
  2. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Are you receiving one or more DID numbers from VoxBone?

    If so, try setting them as DIDs, see: http://www.3cx.com/blog/docs/did-voip-provider/

    regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Orlin,

    Thank you for the suggestion, but it doesn't seem to have gotten me much closer.

    At the moment, I have just one VoxBone number but I do plan on having many. In any case, I did set up the one number as a DID. As to the link you provided that talked about how to configure that, I'm actually running 3CX version 8.0, so what is explained there is a little different for me.

    Nonetheless, on the "Source ID" tab under the VoIP Provider I'm trying to configure for VoxBone, there is a checkbox to do "Source identification by DID" that I believe accomplishes the same thing as described in that link. Unfortunately, it didn't seem to help.

    It just seems to me there's got to be a way to log the calls 3CX is rejecting because it doesn't match the Source ID. That way I could be 100% sure if 3CX seems the calls as hitting it (VoxBone thinks they are) and what values are in the setup that are preventing the matching of the SourceID.

    C.J.
     
  4. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Can't you upgrade to higher version (at least 9) ?
    However, no reason for not working with Version 8. Consult with Version 8 admin manual.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    At the moment, upgrading 3CX versions would be a very big hassle for me. Not to mention that I'm _sure_ this is something with the Source ID and that it should be easily addressable. Check out the below response I got from VoxBone. They are definitely hitting my 3CX system, and I'm sure the 3CX system is just not latching onto the right Souce ID. Believe me, I've played around quite a bit with the "Call Source Identification" fields and the "Source Identification by DID" option; but just haven't gotten it right yet.

    If anyone has any ideas, please help. Thanks! C.J.

    Note, in the below log of VoxBone's INVITE sent to my system, for sake of security, I've replaced our IP address with XXX.

    ===========

    Thank you for the ticket. I see that Voxbone is sending multiple INVITEs to your equipment but your equipment is not responding back. Here is the INVITE:

    U 81.201.84.195:5060 -> XXX.XXX.XXX.XXX:5060
    INVITE sip:13033530534@XXX.XXX.XXX.XXX SIP/2.0.
    Call-ID: RFYTUJL6FZAABFQEC344MUM6YY@81.201.84.195.
    CSeq: 102 INVITE.
    From: "3228080000" <sip:3228080000@voxbone.com>;tag=11976.
    Via: SIP/2.0/UDP 81.201.84.195:5060;branch=z9hG4bK2fd9c821bfa66ee5bc4908fbf2cc6692.
    Max-Forwards: 69.
    Content-Type: application/sdp.
    Contact: <sip:3228080000@81.201.84.195:5060;transport=udp>.
    User-Agent: Vox Callcontrol.
    To: <sip:13033530534@XXX.XXX.XXX.XXX>.
    Content-Length: 313.
    .
    v=0.
    o=root 17925 17925 IN IP4 81.201.84.146.
    s=session.
    c=IN IP4 81.201.84.146.
    t=0 0.
    m=audio 12502 RTP/AVP 0 8 18 101.
    a=rtpmap:0 PCMU/8000.
    a=rtpmap:8 PCMA/8000.
    a=rtpmap:18 G729/8000.
    a=fmtp:18 annexb=no.
    a=rtpmap:101 telephone-event/8000.
    a=fmtp:101 0-16.
    a=silenceSupp:eek:ff - - - -.
    a=ptime:20.
    a=sendrecv.
     
  6. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Hi C.J.,

    in provider's settings, 'source-id' section there is a field 'Call Source Identification', where you match all or any of the fields. Also you may modify SIP fields. Try playing with this settings. Unfortunately I don't have the ability to replicate your case to test it (no version 8 or voxbone account). Eventually I could try it with Version 10.

    Kind regards,
    Orlin.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Ta-da! Got it working.

    Well, for starters, once I figured out that my 3CX system was setup to monitor the non-standard SIP TCP port of 5070 (instead of 5060), this all came together pretty quickly.

    Basically, to use VoxBone as a VoIP Provider (even with my older 8.0 version of 3CX), just follow the "Add Provider" wizard choosing a "Generic SIP Trunk". A couple of important things to keep in mind.

    - What you enter as the "SIP server hostname or IP" doesn't matter that much, unless you want to use VoxBone's source IP as your method of "Source ID" (more on that in a moment), in which case, be sure to know what POP you've set your VoxBone account to send your calls from, and put that IP address in there. VoxBone is good about giving you that info and keeping it consistent.

    - VoxBone does not require authentication to receive their calls, so what you enter in the "External Number", "Authentication ID", and "Authetication Password" does not matter. (Unless you leave the default settings for "Source ID", again, more on that in a moment, in which case you'll want your "Authentication ID" to exactly match the DID/DNIS of the one number you'll be answering from VoxBone.)

    - Remember, VoxBone is an inbound only service, so when the wizard gets you to the "Outbound rules" page, "Skip" it. In addition, once finished setting up the VoxBone VoIP Provider wizard, you'll want to go back to the "Edit Port" page and un-check the "Allow outbound calls on this line" box to be safe.

    - Finally, if you are not familiar with the whole concept of the "Source ID" and how it works in 3CX, familiarize yourself with that with other FAQ's and posts. In short, you are likely going to need to adjust this setting to get your inbound calls to be accepted by your 3CX box. Exactly what you do will depend upon exactly where your comfort level, security concerns, and configuration are at. For example, you can match on VoxBone's source IP address if you want. All of this is controled on the "Source ID" tab for the VoxBone entry you'll create once you are completed with the "VoIP Provider" wizard. For my implementation, I choose the "Source identification by DID" option, and it worked great. I left the "SIP Field containing DID numbers" set to the default setting of "Request Line URI: User Part", and of course made sure all of the DID's (including the leading "1", as VoxBone includes that by default in their E164 setup) were in my list of "Source Identification by DID".

    And then it works like a charm!
     
Thread Status:
Not open for further replies.