Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Web admin interface

Discussion in '3CX Phone System - General' started by jsmack79, Jul 31, 2009.

Thread Status:
Not open for further replies.
  1. jsmack79

    Joined:
    Jul 31, 2009
    Messages:
    12
    Likes Received:
    0
    Should i only be able to access this interface from the computer that 3cx resides on?

    i can't do 192.168.0.0:5481 from any computer, including the one it's on.

    it will only allow 127.0.0.1:5481.


    Is this normal?
     
  2. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    As far as I know the Cassini web service only responds to localhost requests.
    Someone correct me if I am wrong.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jsmack79

    Joined:
    Jul 31, 2009
    Messages:
    12
    Likes Received:
    0
    I'm almost positive I brought it up on my laptop right after I had installed 3cx.... and now it's not responding.
     
  4. jsmack79

    Joined:
    Jul 31, 2009
    Messages:
    12
    Likes Received:
    0
    Update:

    I know for a fact that I could sit down on the 3cx machine and get to the web admin interface by typing in the full IP address.

    Now it only responds to localhost and 127.0.0.1. What did i break?
     
  5. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    Unfortunately I have never used Cassini due to the lack of ability to do SSL and Authentication and IP restrictions.
    And my comment earlier about remote connections must be wrong since phone provisioning and MyPhone obviously works with Cassini.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. houston

    Joined:
    Jul 21, 2009
    Messages:
    40
    Likes Received:
    0
    Turn off the Windows Firewall, and any extra firewall your security software might have added. If it starts working, turn the firewall back on, and adjust firewall settings appropriately.

    The URL is the form of: http://xxx.xxx.xxx.xxx:5481 with the IP address (not localhost, and not 192.168.0.0) of the 3CX substituted in.

    I can say for sure that it works with Cassini on machines other than that which it is installed on. Working with it that way every day.


    After initially posting, it occured to me that your use of "192.168.0.0" MIGHT not have been as a bogus example address, but something you were actually attempting to work with. So I Googled it, just to have something to copy/paste and confirm I wasn't nuts. From About.com:

    .About 192.168.0.0
    Wednesday April 9, 2008
    | Definition | The IP address 192.168.0.0 is the start of the Class C private range. Broadband routers and other network gateways reserve this address to reference the private network. You should not attempt to set 192.168.0.0 as the IP address for your router or any computer as it will not function properly. Some routers are configured instead to use 192.168.0.1 by default that is the first usable address in the range.


    In other words, don't ever set any equipment on your network to end in ".0"
     
Thread Status:
Not open for further replies.