WEBCLIENTURL

Discussion in '3CX Phone System - General' started by imagemaster, May 29, 2017.

Thread Status:
Not open for further replies.
  1. imagemaster

    Joined:
    Jul 20, 2010
    Messages:
    41
    Likes Received:
    1
    After upgrading from 14 Windows to 15.5 Linux, the WEBCLIENTURL shows 5000 when it should be 5001 when the welcome email template is sent. How do I change that? The WEBCLIENTURLPUBLIC is showing the correct port.
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,199
    Likes Received:
    79
    internal 3CX runs on HTTP and not https. Unless you have a split DNS config where by internal under the same fqdn the internal IP resolves this is correct. In split DNS, you can update the email template in settings -> mail -> template to your needs
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. imagemaster

    Joined:
    Jul 20, 2010
    Messages:
    41
    Likes Received:
    1
    I will make the change in the email template but when I go the http it automatically reroutes to https put the port remains 5000 instead of 5001.
     
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,199
    Likes Received:
    79
    I guess you are a chrome user? this is something i fight with every day. Once google chrome notice that an url has answered in in https it will do this for the user... try it in FF and it will not happen...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DL_

    DL_

    Joined:
    Mar 31, 2015
    Messages:
    55
    Likes Received:
    8
    This is due to the Strict Transport Security settings for the site.
    To check the status for a site type chrome://net-internals/#hsts in the address bar on Chrome. Then type the FQDN into the query domain box.

    This will probably show that it has a dynamic STS record. Type the FQDN into the delete domain box to remove it and then it will not redirect to HTTPS. This is part of rfc6797 and due to it not being a standard port (80) it won't try to upgrade the port it will leave it as it is. If that port is not served by HTTPS it will then fail.
     
Thread Status:
Not open for further replies.