WebRTC documentation?

Discussion in '3CX Phone System - General' started by engtech, Mar 1, 2015.

Thread Status:
Not open for further replies.
  1. engtech

    Joined:
    Jun 28, 2014
    Messages:
    3
    Likes Received:
    0
    I am excited to play around with WebRTC. I did the whole backup/unintall/re-install/restore upgrade from 12 to 12.5 last night. I am using a FQDN and have added the new/updated ports for 12.5/WebRTC from here http://www.3cx.com/blog/docs/ports-used/ but I just can't get it to work.

    I decided to go read the documentation and see what I was missing. I pulled up the 12.5 administrator manual and searched for webrtc and there were NO matches. I've also searched the 3cx site and google extensively for 3cx webrtc setup/config etc. and all I can find are pages where 3cx touts all the wonderful features and capabilities of WebRTC but not a damn thing about how to set it up or configure it. This is maddening.

    My "trunk status" for Webrtc has been showing up as "unregistered" and I couldn't find a way to change that. I rebooted the server just for the heck of it and nothing change. Several hours later, it finally switched to a registered status on its own, but my webrtc call links still don't seem to be working. When I paste a link into my browser from a remote location, Chrome just says "establishing secure connection" and then times out. When I try it locally, from Chrome on the computer that is the 3cx server and replace the fqdn with "localhost" or 127.0.0.1 I still get the exact same result, so I think that rules out a port forwarding issue. My firewall on the 3cx server PC is disabled. Maybe I'm missing something. It's entirely possible given what appears to be a complete lack of documentation.

    Thanks if anyone can help shed some light on this.
     
  2. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    790
    Likes Received:
    45
    Hi,

    I think the cause of this issue can be found in the certifying of the used Web Server, Abyss or IIS.
    I almost exactly encounter the same issues as you have.
    If you can skip the error message of Chrome then a user screen will load for the 3CX WebRTC.
    Click the green phone icon and the extension will ring. The “Trunk Status” for WebRTC will go green also.
    In my case if the call is accepted there is no audio or video both ways. Tested with notebooks-deskphone and notebook-notebook.
    Now I am trying to create a real (no self-signed) certificate, but I don’t know how to do that with an Abyss server. I think 3CX have locked the web server somehow.
    See my post: http://www.3cx.com/forums/abyss-ssl-tls-certificates-40985.html

    BTW: there are more forum member who have trouble with the WebRTC.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cjtrevor

    Joined:
    Feb 9, 2012
    Messages:
    64
    Likes Received:
    0
    I get as far as the 3cx screen saying to press the green call button, but when I press it nothing happens. Couldn't find anything in the manual so gave up!
     
  4. mccord

    Joined:
    Feb 8, 2011
    Messages:
    4
    Likes Received:
    0
    I would be interested in documentation as well. To the best of my knowledge, I have set up everything correctly and opened the correct ports in my firewall. I get the screen and click the green call button and nothing happens.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    Hallo,

    1. I have WIN SERVER 2013 with IIS
    2. WebRTC Gateway Is set Hotname: 127.0.0.1 Port 5062
    3. EXT FQDN is set to Routers ext. IP and INT FQDB to IP of 3CX
    4. Port-/Trunk-status Gateway webrtc is red

    What schall I do / test?

    Matthias
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Looks like WebRTC in V.14 is working better.
    For V.12.5 I found a way around to force WebRTC trunk to register is to disable temporary registration and turn on back again, in most cases the trunk will remain registered. Also using a domain name instead of IP address improves behavior.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. ethisec

    Joined:
    May 30, 2015
    Messages:
    2
    Likes Received:
    0
    I'm seeing the same problem here too, even with a legitimate (correctly installed) certificate on an IIS web server.

    Where exactly do you disable temporary registration?

    Jason
     
  8. danielevz

    Joined:
    Jul 6, 2015
    Messages:
    5
    Likes Received:
    0
    for audio to work you must disable STUN in settings, network.
     
  9. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,325
    Likes Received:
    253
    Really? I was just told by my provider to turn STUN on for a more reliable experience. So have I now broken WebRTC?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.