webrtc no audio, no RTP packets

Discussion in '3CX Phone System - General' started by opalbiz, May 8, 2015.

Thread Status:
Not open for further replies.
  1. opalbiz

    Joined:
    Feb 24, 2015
    Messages:
    3
    Likes Received:
    0
    I've setup 12.5 with Webrtc but I cannot get it working at all. No audio between the callers. Webmeeting is working fine, so I know the firewall is setup properly for the RTP port range. Anyone else having this problem?
     
  2. Deepest

    Joined:
    Nov 9, 2012
    Messages:
    45
    Likes Received:
    0

    We are experiencing the exact issue click to call calls setup works correctly and you can use the chat feature on the call but no audio or video packets. Our web meeting works correctly.
     
  3. icg1

    Joined:
    Sep 21, 2011
    Messages:
    1
    Likes Received:
    0
    We faced the same issue in case when IP address of 3CX machine was changed after the installation of the 3CX software.

    The solution, that worked in our case was:
    1. Create 3CX system configuration backup
    2. Find *.xml file in the root folder of backup archive
    3. Locate the followind tag in this XML:
    Code:
    <DNProperty>
       <Type>String</Type>
          <Description>local address of NIC which will be used for WebRTC media connections.</Description>
                <Value>xxx.xxx.xxx.xxx</Value>
          <Name>WRTC_INTERFACE</Name>
    </DNProperty>
    
    if the value is your old IP address change it to the current one.


    4. Place all files back to zip archive
    5. Restore configuration from this archive

    I didn't fount any item in GUI to change this parameter, seems to be a bug in UI.
     
  4. danielevz

    Joined:
    Jul 6, 2015
    Messages:
    5
    Likes Received:
    0
    for audio to work you must disable STUN in settings, network.
     
  5. mdtmed

    Joined:
    Jul 5, 2015
    Messages:
    4
    Likes Received:
    0
    I did it all, but still doesn't work
     
Thread Status:
Not open for further replies.