Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

WebRTC Registration failure

Discussion in '3CX Phone System - General' started by marauder99, Aug 8, 2015.

Thread Status:
Not open for further replies.
  1. marauder99

    Joined:
    Aug 8, 2015
    Messages:
    2
    Likes Received:
    0
    Hello @all,

    I've encountered a strange problem which I can't fix by documentation.

    Since today in the morning, my V.14RC WebRTC won't work anymore. Log shows the password to be incorrect. It says in the Activity Protocol:
    I don't see which passwords I should get to match here, though.

    It repeats the login every few seconds, so the log is full of messages like this:
    In the System - Trunk Status, webrtc gateway is accordingly shown as red. Is there a way to fix this so easy I didn't see it?

    I'm grateful for any help on this.

    Best regards,
    m99
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Hi there,
    The webrtc gateway should be red in normal state, as it registers only when a webrtc call comes in.
    However the log snippet seem to indicate an authentication issue, can you check whether 127.0.0.1 is listed in the WebRTC Gateway / Advanced / Trusted IP Addresses as by default ? and that the "Require Registration for" dropdown is set to "In and Outgoing Calls" ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.