Webserver / IVR fails, Event 1309 code 3009

Discussion in '3CX Phone System - General' started by eberly, Sep 29, 2010.

Thread Status:
Not open for further replies.
  1. eberly

    Joined:
    Apr 14, 2010
    Messages:
    10
    Likes Received:
    0
    Hi all,

    I'm having an ongoing issue with one of my first installs. This is 3cx V9 SP1 on Windows 7 x64 Pro, utilizing Abyss.

    Everything works peachy for the most part, but roughly every 10 days my Webserver and IVR die. I recieve the following in the Windows Error Log:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 9/18/2010 8:40:18 AM
    Event time (UTC): 9/18/2010 12:40:18 PM
    Event ID: 251b886ebada41ab928e5852c305a32a
    Event sequence: 11
    Event occurrence: 2
    Event detail code: 0

    Application information:
    Application domain: 7d33b12f-2-129292846502958984
    Trust level: Full
    Application Virtual Path: /ivr
    Application Path: C:\ProgramData\3CX\Data\Http\Interface\ivr\
    Machine name: 3CX-SERVER

    Process information:
    Process ID: 308
    Process name: fcgidotnet_2_0_x64.exe
    Account name: NT AUTHORITY\SYSTEM

    Exception information:
    Exception type: PhoneSystemException
    Exception message: Config server is not connected

    Request information:
    Request URL: HTTP://localhost:5481/ivr/ivr_start.aspx?IVRHandlerFROM=8566559326&IVRHandlerMENU=RecordMessage&IVRHandlerTO=100&ISID=From_8566559326_To_100_Menu_RecordMessage_%230%2F121
    Request path: /ivr/ivr_start.aspx
    User host address: 127.0.0.1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: NT AUTHORITY\SYSTEM

    Thread information:
    Thread ID: 3
    Thread account name: NT AUTHORITY\SYSTEM
    Is impersonating: False
    Stack trace: at TCX.Configuration.PhoneSystem.Connect()
    at TCX.Configuration.PhoneSystem.get_Root()
    at _Default.Page_Load(Object sender, EventArgs e) in c:\ProgramData\3CX\Data\Http\Interface\ivr\Default.aspx.cs:line 104
    at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
    at System.Web.UI.Control.OnLoad(EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    Custom event details:


    Noone can access the management or Myphone consoles, and the Voicemail is not picking up. However, I can get on via the Windows Management Console, and if I go to the "Services Status" and "Restart All" everything comes backup without a hitch, and their good for another 7 to 10 days.

    I'm guessing I could probably restart services directly from Windows and be fine as well - it's just easier to do it through the WMI 3cx console.

    Any ideas? I'm not a 3CX guru necessarily, but I am an experienced Technician, and I'd like to narrow this down so that my client (and I) don't have to deal with this ongoing maintenance.
     
  2. eberly

    Joined:
    Apr 14, 2010
    Messages:
    10
    Likes Received:
    0
    Anybody have ANY ideas on this?
     
  3. eberly

    Joined:
    Apr 14, 2010
    Messages:
    10
    Likes Received:
    0
    I have not installed the latest 3cx Security release (the bulletin said it was only to update security parameters, no bug fixes), but it is a brand new Win 7 x64 install, only other running application is DualServer DHCP / DNS Server (very simple / basic DHCP / DNS for my network and phones).
     
  4. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Hi, can you still replicate this issue with the latest service pack update?
    Thanks and Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. eberly

    Joined:
    Apr 14, 2010
    Messages:
    10
    Likes Received:
    0
    Just updated - I'm guessing it'll continue, since the service pack was supposed to only address issues related to security and account vulnerability -but I'll let you know what happens.
     
  6. stuart.rendall

    Joined:
    May 26, 2010
    Messages:
    25
    Likes Received:
    0
    Interestingly, I performed a reinstall of the system because of similar problems http://www.3cx.com/forums/abyss-web-server-error-17661.html.

    Shortly after, the anti virus software determined the FGIDOTNET2.0.exe process as malware, and attempted to stop it.

    The anti virus log showed that it had done this previously when the problem had made itself apparent.
     
  7. eberly

    Joined:
    Apr 14, 2010
    Messages:
    10
    Likes Received:
    0
    After Service Pack 3, I haven't had any issues (it is probably 3 weeks since the update). Nothing relevant was listed in the change log, so maybe it was just a permission issue or something that got overwritten with the update. Either way, I'm happy.
     
Thread Status:
Not open for further replies.