Solved Weird inbound call timeouts (3cx sleeping)

Discussion in '3CX Phone System - General' started by Sampl, Jan 17, 2018.

Thread Status:
Not open for further replies.
  1. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    Hi,

    i am experiencing a rather weird behavior on our 3CX system.
    after a while more then an hour or so inbound calls will no longer happen until i make an outbound call first to wake up the trunk or something.
    internal calls and outbound calls always keep working.

    is there a setting that keeps the trunk alive?
     
  2. sip.bg

    sip.bg Active Member

    Joined:
    Nov 7, 2016
    Messages:
    704
    Likes Received:
    219
    Have you run 3CX firewall checker and what is the result ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    Ah, nice one.
    am reading the documentation now on the following errors.

        • testing 3CX SIP Server... failed (How to resolve?)
          • stopping service... done
          • detecting SIP ALG... detected (received ***********) (How to resolve?)
          • testing port 5061... full cone test failed (How to resolve?)
          • starting service... done
        • testing 3CX Tunneling Proxy... done
          • stopping service... done
          • testing port 5090... done
          • starting service... done
        • testing 3CX Media Server... failed (How to resolve?)
          • stopping service... done
          • testing ports [9000..9255]... failed (How to resolve?)
    everything after that was green.
     
  4. apostolis_3CX

    apostolis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    149
    Likes Received:
    15
  5. sip.bg

    sip.bg Active Member

    Joined:
    Nov 7, 2016
    Messages:
    704
    Likes Received:
    219
    Try fixing the issues into your router, 99.9% this causes the "sleep" effect, if using a supported provider, but not only.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    Cool! i disabled SIP ALG on our firewall and it helped all but 1 issue the firewall checker was reporting.

    • resolving 'stun-au.3cx.com'... done
    • resolving 'stun2.3cx.com'... done
    • resolving 'stun3.3cx.com'... done
    • resolving 'sip-alg-detector.3cx.com'... done
    • testing 3CX SIP Server... failed (How to resolve?)
      • stopping service... done
      • detecting SIP ALG... not detected
      • testing port 5061... full cone test failed (How to resolve?)
      • starting service... done
    • testing 3CX Tunneling Proxy... done
      • stopping service... done
      • testing port 5090... done
      • starting service... done
    • testing 3CX Media Server... done
      • stopping service... done
      • testing ports [9000..9255]... done
        • testing port 9000... done
        • testing port 9001... done
        • testing port 9002... done

    working on that part and will let you know what the results are.
    Thanks!
     
  7. sip.bg

    sip.bg Active Member

    Joined:
    Nov 7, 2016
    Messages:
    704
    Likes Received:
    219
    What make is your router and does it have any built-in phone ports ?
    Some routers have built-in VoIP functionality and utilize ports 5060, 5061.
    If so, you need to disable them or change ports used (e.g. to 5160, 5161).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    i have Sophos XG210 firewall
     
  9. sip.bg

    sip.bg Active Member

    Joined:
    Nov 7, 2016
    Messages:
    704
    Likes Received:
    219
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    Hi Guys,

    the issue has been fixed.
    it was settings on our firewall i had our IT service provider (WAN Managers) have a go at it at some point yesterday and they have informed me that the issue is now fixed, which i can confirm. i will give them a call on Monday for the explanation on how they fixed it and post that here.

    Thanks for your help!
     
  11. apostolis_3CX

    apostolis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    149
    Likes Received:
    15
    Hi Sampl,
    Glad to hear your issue was resolved.
    We will be waiting for your feedback.
     
  12. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    21
    Likes Received:
    5
    Hi All,

    so what fixed the final port issue we were having was to unload the SIP Helper as well.
    Thank you all for the help!
     
Thread Status:
Not open for further replies.