Weird sound when dialing out (3CX Skype Gateway).

Discussion in '3CX Phone System - General' started by nbains, Feb 19, 2011.

Thread Status:
Not open for further replies.
  1. nbains

    Joined:
    Feb 18, 2011
    Messages:
    2
    Likes Received:
    0
    Hi Everyone,

    Sorry if this problem exists somewhere else, I briefly looked at the other pages but didn't find anything.

    I have a 3CX Server installation (non licensed, using for testing) on a Server 2008 machine, with two Cisco 7940 phones
    successfully upgraded to SIP. (I can call between these two phones and hear myself fine.)
    I have a Skype account linked with 3CX via a Skype for 3cx Gateway, setup a PSTN line and an outbound rule.

    Whenever I try calling from my SIP extension to a landline, the phone will dial out, but AS SOON as the other person picks it up, the Cisco phone will return a "jackhammer drilling sound effect" and the person on the recieving end of the call just hears silent dead air. Even my Skype Credit goes down, so it seems like the skype account is recognizing the call.


    Here are the Server logs when making the call. Note: I terminated the call manually after the other person picked the phone up. (6 seconds of the jackhammer noise):


    15:55:03.691 [CM503008]: Call(2): Call is terminated
    15:54:55.903 [CM503007]: Call(2): Device joined: sip:10000@127.0.0.1:6060;rinstance=7c4050ee7394129f
    15:54:55.897 [CM503007]: Call(2): Device joined: sip:4206@192.168.1.107:5061;transport=udp
    15:54:51.052 Currently active calls - 1: [2]
    15:54:45.976 [CM505002]: Gateway:[Skype-Test] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.9919.0] PBX contact: [sip:10000@127.0.0.1:5060]
    15:54:45.975 [CM503002]: Call(2): Alerting sip:10000@127.0.0.1:6060;rinstance=7c4050ee7394129f
    15:54:45.566 [CM503025]: Call(2): Calling PSTNline:001250xxxxxx@(Ln.10000@Skype-Test)@[Dev:sip:10000@127.0.0.1:6060;rinstance=7c4050ee7394129f]
    15:54:45.444 [CM503004]: Call(2): Route 1: PSTNline:001250xxxxxx@(Ln.10000@Skype-Test)@[Dev:sip:10000@127.0.0.1:6060;rinstance=7c4050ee7394129f]
    15:54:45.385 [CM503010]: Making route(s) to <sip:xxxxxxx@192.168.1.12>
    15:54:45.378 [CM505001]: Ext.4206: Device info: Device Identified: [Man: Cisco;Mod: 7940;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [Cisco-CP7940G/8.0] PBX contact: [sip:4206@192.168.1.12:5060]
    15:54:45.366 [CM503001]: Call(2): Incoming call from Ext.4206 to <sip:xxxxxxx@192.168.1.12>



    Also, my Firewall checker:

    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <16:04:06>: Phase 1, checking servers connection, please wait...
    <16:04:06>: Stun Checker service is reachable. Phase 1 check passed.
    <16:04:06>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <16:04:16>: UDP SIP Port is set to 5060. NO RESPONSE received. Phase 2a check FAILED.


    Application exit code is -2



    I have set Port Forwarding on my router for Port 5060 - UDP and TCP, so I'm not sure what this signifies..


    Any help would be appreciated, if you need more details, just ask, thanks!

    Neil
     
  2. nbains

    Joined:
    Feb 18, 2011
    Messages:
    2
    Likes Received:
    0
    Hi Everyone,

    I solved the problem. The audio drivers weren't installed on the server. Once I installed them, made a call and we were good to go! Easy solution...

    Thanks.
     
Thread Status:
Not open for further replies.