Welcome Email Config File - Change Configuration

Discussion in '3CX Phone System - General' started by Cajun McCartney, Mar 29, 2018.

Thread Status:
Not open for further replies.
  1. Cajun McCartney

    Joined:
    Dec 15, 2017
    Messages:
    19
    Likes Received:
    0
    Hi all,

    I am doing final steps on a test 3cx environment for my office and before I have people start using it, I want to make sure they get their welcome email and can be setup and ready to go.

    The issue I am having is the config file that is generated for the welcome email is configuring their phone/account profile with the local IP of the server for the "In Office" location and it's preventing the phone from connecting. I need it to use the FQDN that it is using for "Out of Office". I have the system built in AWS and even though I gave it a static public IP and FQDN, it is sending the config file out with the local server IP.

    I found some parameters in the management console, but I want to make sure I change the correct ones.

    Attached is a list of the parameters with the local IP and below are the values in the generated 3CXprov config file that I need to change from local IP to FQDN. How can I make it so the config files get generated with the FQDN without breaking anything?

    <PBXLocalAddr>10.5.2.64</PBXLocalAddr>
    <ProvLink>https://10.5.2.64:5001/provisioning/cmw16gqvqm042l/TcxProvFiles/3cxProv_BSY9JN1P6R7108.xml</ProvLink>
    <MyPhoneServerLocalSSLAddr>https://10.5.2.64:5001/myphone/MPWebService.asmx</MyPhoneServerLocalSSLAddr>
     

    Attached Files:

  2. V..

    V..

    Joined:
    Feb 14, 2017
    Messages:
    62
    Likes Received:
    23
    The softphone is designed to work and we run with the same setup albeit on OVH rather than AWS.

    You can set the default interface to the FQDN within the provisioning options for the 3CX client.
    upload_2018-4-9_17-31-33.png
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    bdarcyevans and craigreilly like this.
  3. bdarcyevans

    Joined:
    Apr 6, 2015
    Messages:
    50
    Likes Received:
    3
    I had something similar (https://www.3cx.com/community/threa...relationship-to-pbx-configuration-tool.55543/) and found that changing the 'Network interface for registration and provisioning' to the FQDN for the '3CX Client' only for each respective extension appeared to be enough to revert the welcome email back to providing only the single link as desired (as per above suggestion).

    Just check that you can set this during extension creation, and it works as expected. If not, you may need to create the extension (without email to prevent auto sending of welcome email), fix settings, add email and then send welcome email.
     
  4. Saqqara

    Saqqara Active Member

    Joined:
    Mar 12, 2014
    Messages:
    939
    Likes Received:
    149
  5. mikem

    Joined:
    Mar 30, 2018
    Messages:
    4
    Likes Received:
    1
    "auto sending of welcome email" can be turned off at Settings -> Email -> Notifications -> 'Notify user when extension is added' checkbox
     
    bdarcyevans likes this.
Thread Status:
Not open for further replies.