Wellgate 2540 4 POTS lines into system and no caller id name

Discussion in '3CX Phone System - General' started by johncpatterson, Nov 20, 2015.

Thread Status:
Not open for further replies.
  1. johncpatterson

    Joined:
    Nov 20, 2015
    Messages:
    5
    Likes Received:
    0
    I have a welltech wellgate 2540 setup to receive and send calls on a set of POTS lines. All calls are fine in and out.
    Our old system allowed us to see the name of the caller coming from the telephone company. For the life of me, I can't seem to find out where to change it to add it. I've tried extending the rings on the pstn. I've tried differenct telco options on the gateway. I've tried changing variables on the PSTN inbound side with no luck as well.

    Currently the gateway is set to 3 second delay and 2 second ring. I've doubled that to see if it would work and it does not.
    I've checked incoming POTS line with standard caller id phone and all is good with number and name.

    The system is showing the Pots line number for both.

    Any input would be appreciated.
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,978
    Likes Received:
    183
    The Gateway should allow you to run a trace so you can see what field the information is coming in on so you can update the configurations...
    And try an analog phone just to ensure the info is still coming in.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,373
    Likes Received:
    230
    Other than increasing the "ring time", to allow for collection of the CID info, and , as suggested, checking to see if there really is CID info being sent, the other thing I would suggest is checking to be sure that the CID type, for your region, on the gateway, is set correctly. If the gateway had been reset, and then re-provisioned, then that may have changed.
     
  4. johncpatterson

    Joined:
    Nov 20, 2015
    Messages:
    5
    Likes Received:
    0
    bump. both lines show a number and name and id are coming through the stand alone phone and the old system.
    USA Region Bellcore FSK.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,373
    Likes Received:
    230
    If the 3CX server log of an incoming call shows no CID info, then I have to assume that the call is being passed too quickly to the PBX. You may have to increase the time by a second or two. Three seconds is a bare minimum with Bellcore CID type. The data is normally send between the first and second ring, but, depending on the CO switching equipment type, that could vary by a few seconds. Increase the time and see what happens.
     
  6. johncpatterson

    Joined:
    Nov 20, 2015
    Messages:
    5
    Likes Received:
    0
    I've increased the ring count by 4 fold with no luck. Is that what you are referring to? Thanks,
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,373
    Likes Received:
    230
    I'm not sure what the option is called on your particular gateway. When changed it should increase the time from initial ringing to when the call is "passed on" to 3CX. If the time is too short, then 3CX is notified before the CID information is received on the PSTN line.
     
  8. Aram

    Aram Support Team
    Staff Member 3CX Support

    Joined:
    May 7, 2012
    Messages:
    87
    Likes Received:
    19
    Hi johncpatterson,

    To enable the display name on wellgate device do the following:
    1. Login as admin and go to SIP Trunk tab;
    2. Edit the trunk (click on orange arrow) and choose needed parameter from the "Display Name" drop-down list;
    3. Repeat this for all trunks.

    That is all.
     
  9. capitol1

    Joined:
    Jul 11, 2011
    Messages:
    20
    Likes Received:
    0
    Here is some additional clarification on the solutions.

    To Resolve the issue, the Wellgate must be running Firmware wg25.4.02a
    http://www.welltech.com/support/voip2/SIP series/FXSO series/25xx/v4.02a/wg25.4.02a.zip

    1) Apply firmware
    2) Reboot
    3) Click SIP Trunk
    4) Click Orange modify icon next to Trunk
    5) Under Outgoing Caller ID: Set "Display Name" to "PSTN Caller Name"
    6) Under Outgoing Caller ID: Set "User ID" to "PSTN Caller ID"
    7) Click Apply
    8) Repeat steps 4,5,6,7 for all 4 Trunk ID's.
     
Thread Status:
Not open for further replies.