Wifi trouble with Yealink T46G

Discussion in '3CX Phone System - General' started by engin411, Apr 27, 2017.

Thread Status:
Not open for further replies.
  1. engin411

    engin411 New Member

    Joined:
    Jul 3, 2009
    Messages:
    172
    Likes Received:
    0
    3cx v15, latest update, and Yealink T46G phones, latest firmware, latest template, with the WIFI settings configured like this:
    #######################################################################################
    ## Wifi (Only for T48G\T46G\T29G\T48S\T46S) ##
    #######################################################################################
    wifi.enable = 1
    wifi.1.label = KFF
    wifi.1.ssid = VOIP
    wifi.1.security_mode = WPA2-PSK
    wifi.1.cipher_type = CCMP
    wifi.1.password = <password>
    wifi.1.priority = 5

    These settings don't appear to do anything. I followed this procedure:
    - edit template on 3cx (edited the default template with the above WIFI settings)
    - boot phone without any WiFi dongle from PoE and assigned that template
    - unplug phone from PoE
    - plug WiFi dongle
    - plug power adapter

    The phone not only does not connect to the WIFI (which is the expected behavior), but when I use the phone dialog to manually connect to the WIFI, it asks for the WIFI password. So the settings in the template don't appear to be doing a thing.

    I have gotten these phones to connect to the WIFI successfully when I use the web interface to configure it. So the dongle and the WIFI do work, but not when I use the 3cx template to provision the phones.

    Ideas what to do next?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,407
    Likes Received:
    458
    Have you tried restarting the management console service after you did changes to the template? That is necessary for the changes to take effect
     
  3. engin411

    engin411 New Member

    Joined:
    Jul 3, 2009
    Messages:
    172
    Likes Received:
    0
    Yes, I did that this morning to verify. Nothing changes. The phone does not connect. It asks me to scan, and it sees the WIFI, but on telling it to connect, it asks for a password.
    It should connect immediately with no intervention.
     
  4. engin411

    engin411 New Member

    Joined:
    Jul 3, 2009
    Messages:
    172
    Likes Received:
    0
    I have a tip from another user to put quotation marks around the cipher value. Does this make sense to you?
    For wifi.1.cipher_type = CCMP, he had wifi.1.cipher_type = "CCMP"
     
Thread Status:
Not open for further replies.