Windows 7/Acer Aspire 5532 Laptop, no sound after connection

Discussion in 'Windows' started by craigarno, Dec 13, 2010.

Thread Status:
Not open for further replies.
  1. craigarno

    Joined:
    Dec 13, 2010
    Messages:
    2
    Likes Received:
    0
    3CX works fine on my Vista/HP Pavilion laptop at the same remote location and network that Windows 7/Acer Aspire 5532 does not.

    On the Windows 7/Acer Aspire 5532, I can see on my remote Asterisk console that I'm registering correctly, and when I make a call I hear ringing... then when the call is completed, silence. I tried my "Echo Test" number and don't hear the announce message on the Windows 7/Acer Aspire 5532. This same echo test works fine on the Vista/HP Pavilion platform.

    The two laptops are configured as different extensions. At this same remote location, I have a Sipura SPA3000 configured as yet another extension. The 3CX-Vista/HP Pavilion combo can call the SPA3000 and carry on a full duplex conversation. The Windows 7/Acer Aspire 5532 combination can call the other two, but no sound in either direction. The Acer may not have a microphone, but does have speakers, so I'd expect to at least be able to hear the other side of the conversation.

    Does anyone know why sound won't play under Windows7?
     
  2. craigarno

    Joined:
    Dec 13, 2010
    Messages:
    2
    Likes Received:
    0
    Re: Windows 7/Acer Aspire 5532 Laptop, no sound after connec

    I hate to respond to my own post... I fiddled with Windows 7 for too long and couldn't get this working. My conclusion is 3CX just doesn't work with some Windows 7 installations, like mine.

    I found this program works for me under Windows 7 http://www.counterpath.com/x-lite.html. If I get feedback on how to fix this issue with Windows 7/3CX, or that there is a new 3CX softphone release, I'll be happy to switch back. I like the 3CX interface.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,750
    Likes Received:
    285
    Re: Windows 7/Acer Aspire 5532 Laptop, no sound after connec

    Have you assigned a unique port number to each device at the same remote location?

    I have seen occasions where routers become a bit confused as to which device to send the voice packets to and if you've left the port number at the default of 5060 on both 3CX phone installs it will only add to the problem

    I've use the 3CX phone on a netbook running Win 7 Ultimate, with no issues.
     
Thread Status:
Not open for further replies.