Windows Installer version smaller than 4.5

Discussion in '3CX Phone System - General' started by luv2geek, Mar 13, 2012.

Thread Status:
Not open for further replies.
  1. luv2geek

    Joined:
    Mar 13, 2012
    Messages:
    2
    Likes Received:
    0
    I am new to 3CX, and these forums, so I have taken it open myself to search this installation error I got on my first attempt to install this software. It seems many users uninstall .NET Framework 4 to get resolve this, but I do not have any Framework updates or packages installed. This is Windows 2008 R1 32bit version. Under add/remove programs the .Net 3 Framework is installed.

    I am not sure if I need to search and download this or let the installer put it on this system, several forum posts conflict on what resolves this.

    Also I have not installed IIS, not sure if the wizard wants to do that as the pre-req in the installation guide doesnt say anything about it, but apparently it is used for the portal and provisioning.

    Any help is appreciated. Here is a screen shot of the error.

    [​IMG]Click for large view - Uploaded with Skitch
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Hi,

    The only thing you should install is a .Net Framework 4.5. Everything else will be downloaded and installed by 3cx installer. During installation you will be asked what web server do you want to use and installer will install and setup for you automatically. Enjoy 3cx Phone System!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. luv2geek

    Joined:
    Mar 13, 2012
    Messages:
    2
    Likes Received:
    0
    LOL I just installed WIndows Installer 4.5 and now see that Framework 3.5 is too low, etc. I am download 4.5 BETA right now.

    Is it correct that we are using the beta?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Sorry. Use .Net 4.0. Windows installer is 4.5. I'm lost in numbers :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. efounco

    efounco New Member

    Joined:
    Sep 28, 2011
    Messages:
    148
    Likes Received:
    4
    Personally, I'm not real keen on letting my users install their own system dependencies and have most installation privileges locked down via GPO. As such, I've simply created a Sysprep deployment image with Windows Installer 4.5, .Net 4.0 Sliverlight 5.0 and Visual Studio 2005 tools for Office (for Office 2003) preinstalled. The default profile puts a link to 3CX Myphone on their desktop. Users have the option of installing/using the Silverlight stand-alone application or simply using the WEB interface.

    Personally, I think the 3CX Myphone application has an absurd amount of system dependencies for what little it does. Also, something requiring so many dependencies should NEVER require end-user interaction to install. Instead, there should be an installation/deploy-able package of 3CX MyPhone that includes everything required to run it.
     
  6. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    You will have to use Windows Installer 4.5.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.