Windows phone fails to connect after 1st call

Discussion in 'Windows' started by venkman, Jan 29, 2016.

Thread Status:
Not open for further replies.
  1. venkman

    Jul 22, 2015
    Likes Received:

    I am in the process of setting up 3CX as a proof of concept.

    I have installed the 3CX softphone on my Windows 10 PC, and I am testing with an echo test *777 (on the internal network). When I first open the application and dial *777, I am able to call OK. However, when I finish the call and then try to call again ... nothing ... I get call failed every time (and no more events in the activity log, no matter how many times I try to call).

    If I close the application and reopen, I'm then able to call *777 the first time again, but subsequent attempts fail.

    The verbose logs I have are below, if anyone could shed any light on this issue I would very much appreciate it:

    29-Jan-2016 11:53:41.705 Leg L:10.2[ParkOrb:*777] is terminated: Cause: BYE from PBX
    29-Jan-2016 11:53:41.705 [CM503008]: Call(C:10): Call is terminated
    29-Jan-2016 11:53:41.704 Leg L:10.1[Extn] is terminated: Cause: BYE from
    29-Jan-2016 11:53:35.058 Currently active calls - 1: [10]
    29-Jan-2016 11:53:22.523 [CM503007]: Call(C:10): ParkOrb:*777 has joined, contact <sip:*777@>
    29-Jan-2016 11:53:22.516 [CM503007]: Call(C:10): Extn:102 has joined, contact <sip:102@>
    29-Jan-2016 11:53:22.514 L:10.2[ParkOrb:*777] has joined to L:10.1[Extn]
    29-Jan-2016 11:53:22.514 NAT/ALG check:L:10.2[ParkOrb:*777] RESPONSE 200 on 'INVITE' - basic check passed. No information for extended checks
    29-Jan-2016 11:53:22.460 [CM503025]: Call(C:10): Calling T:parkOrb:*777@[Dev:sip:*777@;rinstance=ee2d83d57a6d1a68] for L:10.1[Extn]
    29-Jan-2016 11:53:22.412 [CM503027]: Call(C:10): From: Extn:102 ("Jonathan Marshall" <sip:102@>) to T:parkOrb:*777@[Dev:sip:*777@;rinstance=ee2d83d57a6d1a68]
    29-Jan-2016 11:53:22.412 [CM503004]: Call(C:10): Route 1: from L:10.1[Extn] to T:parkOrb:*777@[Dev:sip:*777@;rinstance=ee2d83d57a6d1a68]
    29-Jan-2016 11:53:22.411 [CM503001]: Call(C:10): Incoming call from Extn:102 to <sip:*777@>
    29-Jan-2016 11:53:22.410 NAT/ALG check:L:10.1[Extn] REQUEST 'INVITE' - some of SIP/SDP headers may contain inconsistent information or modified by intermediate hop
    SIP contact header is not equal to the SIP packet source(IP:port):
    Contact address:
    Received from :
    29-Jan-2016 11:52:41.432 [CM504002]: Endpoint Extn:102: a contact is unregistered. Contact(s): [sip:102@ / 102]
    29-Jan-2016 11:52:41.237 [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@ / 102,sip:102@ / 102]
    29-Jan-2016 11:52:41.095 [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@ / 102]
    29-Jan-2016 11:52:36.929 [CM504002]: Endpoint Extn:102: a contact is unregistered. Contact(s): []
  2. Charles_3CX

    Charles_3CX New Member
    3CX Support

    Jul 6, 2015
    Likes Received:
    Hi There

    Check that you have a microphone configured within the 3CXPhone for Windows under settings audio options. If you have chosen the primary sound device then make sure that you have a headset specified as the default device for both playback and recording within the sound settings in the windows control panel or at least a microphone and speakers chosen. Better still, if you have a headset, specifically choose the headset for both microphone and speakers under the audio options of 3CXPhone.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.