XML Returning from code component. A '<' character cannot b

Discussion in 'CRM / Helpdesk / App Integration' started by SWSDEV, Mar 17, 2010.

Thread Status:
Not open for further replies.
  1. SWSDEV

    SWSDEV Member

    Joined:
    Feb 23, 2008
    Messages:
    256
    Likes Received:
    0
    This is from the ivr error log

    messageXML parsing error in file VadTools_SMS_MF_runSMS_DoIt.aspx, line 18: A '<' character cannot be used in
    attribute 'expr', except through &lt;


    There is an XML string being returned from an external code component.

    How can I accept the string properly?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    This seems to be a bug in the VAD. We're going to investigate it and fix it.
    Meanwhile, try returning the XML escaping invalid characters. Can you do that? Are you able to change the code executed by the External Code Component?
     
  3. SWSDEV

    SWSDEV Member

    Joined:
    Feb 23, 2008
    Messages:
    256
    Likes Received:
    0
    Yes, I could change the code. For now I just extracted one of the values from the XML to return instead, but I'll try changing the characters also.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    Hi Shahzad,

    Thanks for reporting the error. We're going to fix it in the next release.

    Regards,
     
Thread Status:
Not open for further replies.