Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Yealink phones won't connect to server with approved TLS cert

Discussion in '3CX Phone System - General' started by seantp, Mar 28, 2018.

Thread Status:
Not open for further replies.
  1. seantp

    Joined:
    Sep 9, 2017
    Messages:
    38
    Likes Received:
    2
    I'm using a cert issued by Comodo RSA Domain Validation Secure Server CA, which is on Yealinks list of trusted certificates. However, I still have to go to phones and manually disable Only Accept Trusted Certificates. It's very frustrating and I've gone to lengths of customizing the yealink config files to disable that setting. It still requires the initial disable to even provision new phones

    I don't really remember having to install the root certificate on the server and wonder if adding that to the cert chain would help.
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,435
    Likes Received:
    188
    Hi seantp,

    This should not be required anymore but was with an older version of firmware (for remote STUN extensions at the very least). Please confirm what Yealink model and FW version you are using.
     
  3. seantp

    Joined:
    Sep 9, 2017
    Messages:
    38
    Likes Received:
    2
    My remote worker is using a
    T46S
    Firmware Version
    66.82.0.20

    Hardware Version
    66.0.0.128.0.0.0

    I'm using
    T48G

    Firmware Version 35.82.0.20
    Hardware Version 35.1.0.2.1.0.0

    For as long as I have been using this combination of 3CX and yealink phones. The first step I take is disabling "Only Accept Trusted Certificates" so I could then provision the device successfully.
     
Thread Status:
Not open for further replies.