YeaLink T38G "OEM OEM" and Time

Discussion in '3CX Phone System - General' started by Mullenlaw, Nov 30, 2011.

Thread Status:
Not open for further replies.
  1. Mullenlaw

    Joined:
    Apr 13, 2011
    Messages:
    53
    Likes Received:
    0
    I have a bunch of T38Gs that show up as "OEM OEM" instead of "Yealink T38G"....

    I can select the T38G in provisioning and it's fine, but the DATE/TIME is not setting correctly.

    What determines which model/time setting is used? The template? or the phones ID (being OEM OEM)...

    How can I get 3cx to set the time correctly? :cry:
     
  2. paul1

    Joined:
    Jan 14, 2010
    Messages:
    80
    Likes Received:
    0
    Once the phone is set to the proper template it should work. Did you set the Yealink Time setting in the General Tab of the Phone provisioning page?
     
  3. Mullenlaw

    Joined:
    Apr 13, 2011
    Messages:
    53
    Likes Received:
    0
    My thread got highjacked !
    Edit Vali_3CX: cleaned

    Yes, I am assigning the model and the timezone is set....

    I think I found that the DHCP time option on the phone is not set. So that is something I need tp change in the template, right?

    That said, how do people manage customizing their templates and having 3cx issue updated ones. Won't my changes get squashed ?
     
  4. paul1

    Joined:
    Jan 14, 2010
    Messages:
    80
    Likes Received:
    0
    You can rename the template file and the phone names within the file so future 3cx updates don't overwrite your templates.

    I have added SS to the model names in this example. That way when I select a phone model on an extensions provisioning tab I can see that I am choosing my custom template.

    <models>
    <model>Yealink SS T32</model>
    <model>Yealink SS T38</model>
    </models>
     
  5. Mullenlaw

    Joined:
    Apr 13, 2011
    Messages:
    53
    Likes Received:
    0
    Well, still having a problem with DHCP time setting. It just isn't working and I don't know why....

    It's not the time zone because the DATE is wrong as well.

    It appears to be a network issue....

    We use 192.168.10.x and 192.168.11.x internally... subnet 255.255.254.0

    11.x phones cannot get the time for some reason and I'm not sure why. The subnet mask should be correct and the 11 phones can talk to .10.x or .11.x phones without issue.....

    Any suggestions? :oops:
     
  6. paul1

    Joined:
    Jan 14, 2010
    Messages:
    80
    Likes Received:
    0
    Does your time server have a proper subnet mask? If your time server is 192.168.10.x and has a mask of 255.255.255.0 it would not be able to respond to the phones on 192.168.11.x
     
  7. Mullenlaw

    Joined:
    Apr 13, 2011
    Messages:
    53
    Likes Received:
    0
    Found the problem. Our router was blocking it because it was only allowing .10.x addresses.... :O

    Thanks for the suggestion
     
Thread Status:
Not open for further replies.