Yealink VP2009 Issues - Won't Register3CX V10**FIRMWARE PROB

Discussion in '3CX Phone System - General' started by HurdIT, Apr 13, 2011.

Thread Status:
Not open for further replies.
  1. HurdIT

    Joined:
    Apr 13, 2011
    Messages:
    11
    Likes Received:
    0
    We have the Yealink VP2009 units with the following firmware and release.
    Hardware Version VideoPhone-V8438
    Software Version 22.21.0.60

    Here's the steps we performed below:

    1. The unit is configured to factory default settings.
    2. We configure the DHCP server with the MAC address of the unit and the DHCP option #66 for the URL to retrieve the config as we have done for the other Yealink phones which works flawlessly.
    3. We configure 3CX to use the Yealink VP2009 model, exactly in the same manner as the other Yealink phones.
    4. Plug in the phone and let the phone boot up. We see the DHCP server issue the IP address. We see the phone appear in 3CX as the following:
    Phone Model: VideoPhone 22.21.0.60
    Name : new
    User ID: new
    User Password: new
    PIN: new
    Firmware: 22.21.0.60

    Using the IP address, I can login to the web-interface of the phone.

    If I try to assign the phone to an extension and reboot the phone, there is no change.

    I can manually configure the phone using the account info and the phone will work however none of the other functions can be provisioned to the phone. I have tested this with three VP2009 units and all have the same issue. I also re-created the user account and tried different accounts.

    I can consistantly reproduce the issue.
     
  2. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    Re: Yealink VP2009 Issues - Won't Register with 3CX V10

    I have the same issue but the problem is not with V10 but with the firmware on the phone. If you check out wireshark while you try to provision the phone it doesn't respond to the PBX request which is sent multiple times up to 10 I believe before giving up. I have tried provisioning multiple VP2009's with no success except manual configuration.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. HurdIT

    Joined:
    Apr 13, 2011
    Messages:
    11
    Likes Received:
    0
    Re: Yealink VP2009 Issues - Won't Register with 3CX V10

    I think that with all the firmware updates floating around, I think we need a place to track the versions in this forum. Does anyone at 3CX know the version of firmware they tested with? If we can get that version, then we can resolve the issue and document it for everyone.

    Thanks for verifying the issue.
     
  4. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    Re: Yealink VP2009 Issues - Won't Register with 3CX V10


    When I tested it I used the most recent firmware version from Yealink, I have reported the issue to yealink and I hope we see results soon. But depending on the model there are two different versions, here is a link to available firmware for these phones: http://www.yealink.com/index.php/Support/.

    I am having similar issues with other Video Phones not just the yealink VP2009.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Re: Yealink VP2009 Issues - Won't Register3CX V10**FIRMWARE

    I am using firmware 22.21.0.90 and although Plug-And-Play provisioning doesn't work, the phone registers and can make and receive calls just fine when manually configured.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.