Yealink VP530 Loses Registration Often

Discussion in '3CX Phone System - General' started by Jimstigator, Jan 3, 2013.

Thread Status:
Not open for further replies.
  1. Jimstigator

    Joined:
    Dec 21, 2012
    Messages:
    17
    Likes Received:
    0
    Hey there,

    New phone system is moving alone nicely with one major hitch.

    The Yealink VP530s (v23.70.0.40) are dropping their registration far more often than I think they should. For example... my extension "1010" unregistered yesterday at 5pm. It didn't reregister until 4am today according to the "Server Event Log"

    Any idea what causes this and where I can adjust? The obvious issue with it is the phones will kick incoming calls straight to VM when it happens, so the user never knows the call came in. I adjusted the system to push the call through anyway if the phone is unregistered, but that doesn't really solve the bigger issue.

    Thanks!
    Jim
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Is this phone local or remote?
     
  3. Jimstigator

    Joined:
    Dec 21, 2012
    Messages:
    17
    Likes Received:
    0
    Technically remote, but to the system, its local. Networked in via VPN tunnels between our gateways. Atleast local in the sense that we don't use the 3cx vpn functionality.

    But... This is only happening to a few of over 50 phones, most of which are working flawlessly. Mine in particular, loses registration daily when none of the others will.

    Today it dropped registration 3-4 times and no others did. Yesterday mine and a different phone did it a few times.

    Jim
     
  4. 3CXfoxhallsolutions

    3CXfoxhallsolutions New Member

    Joined:
    Sep 8, 2012
    Messages:
    211
    Likes Received:
    0
    Hi Jim
    I assume that since you are working via VPN, that the subnets are different at the 3CX site, and at the remote site - so - my experience is that you still need to set up the Yealink phone as a remote extension - even tho' you are not using the public IP address of the remote site in the account settings.
    In other words, you need to set the account in each phone with;
    - SIP Server set to LAN IP address of the 3CX server [port 5060]
    - NAT Traversal - STUN
    - STUN server set to LAN IP address of the 3CX server
    - Keep alive messages UDP
    - UDP Keep-alive - 20 sec's
    - RPort Enabled

    and I also set a short subscribe period [120 sec's] so if things do get disconnected, they reconnect fairly quickly.

    Hope that helps ...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Jimstigator

    Joined:
    Dec 21, 2012
    Messages:
    17
    Likes Received:
    0
    Thanks for the advice!

    I was just pondering the same solution, and posted this thread... http://www.3cx.com/forums/vpn-through-gateway-router-or-phones-32925.html

    I'll give it a go on a few of the trouble maker phones and see how it works.

    Thanks again,
    Jim
     
Thread Status:
Not open for further replies.