Yet Another "They Can Hear Me But I Can't Hear Them" thread

Discussion in '3CX Phone System - General' started by semose, Jan 11, 2012.

Thread Status:
Not open for further replies.
  1. semose

    Joined:
    Jan 11, 2012
    Messages:
    7
    Likes Received:
    0
    Apologies in advance, I'm sure this is a maddeningly common topic. However, I think I've done my due-diligence trying to track down this issue on my own, so I think I'll open it up to the experts now.

    I'm trying to set this up at work. I had it working with my personal VoIP provider account (VoIP.ms), but deleted the settings when my boss gave me a company account to test with. As such, the firewall test passes without warnings/errors. The firewall is a Juniper SSG-5. 3CX Phone System is running on Server 2008 R2. The OS firewall is disabled for testing purposes. The 3CX server has a static Public IP address, STUN is turned off, and said Public IP is configured in the Settings -> Network -> STUN server tab. I've created extension 20 and registered it with the 3CX softphone software on my desktop, which is in the same subnet as 3CX Phone System. Below is the verbose log of extension 20 dialing extension *777 (Echo test):

    Code:
    15:42:36.555  [CM503008]: Call(7): Call is terminated
    15:42:19.984  Currently active calls - 1: [7]
    15:42:18.918  Session 571 of leg C:7.1 is confirmed
    15:42:18.732  [CM503007]: Call(7): Device joined: sip:*777@127.0.0.1:40000;rinstance=4c97d9cdde3a504c
    15:42:18.726  [CM503007]: Call(7): Device joined: sip:20@{SOFTPHONE IP}:64129;rinstance=29b9df9ea7d3ad80
    15:42:18.724  [MS210005] C:7.1:Answer provided. Connection(proxy mode):{3CX INTERNAL IP}:7014(7015)
    15:42:18.721  [MS210001] C:7.2:Answer received. RTP connection[unsecure]: 127.0.0.1:40012(40013)
    15:42:18.720  Remote SDP is set for legC:7.2
    15:42:18.717  [CM505001]: Ext.*777: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Echo Test] PBX contact: [sip:*777@127.0.0.1:5060]
    15:42:18.717  [CM503002]: Call(7): Alerting sip:*777@127.0.0.1:40000;rinstance=4c97d9cdde3a504c
    15:42:18.562  [CM503025]: Call(7): Calling Ext:Ext.*777@[Dev:sip:*777@127.0.0.1:40000;rinstance=4c97d9cdde3a504c]
    15:42:18.560  [MS210004] C:7.2:Offer provided. Connection(proxy mode): 127.0.0.1:7016(7017)
    15:42:18.526  [CM503004]: Call(7): Route 1: Ext:Ext.*777@[Dev:sip:*777@127.0.0.1:40000;rinstance=4c97d9cdde3a504c]
    15:42:18.525  [CM503010]: Making route(s) to <sip:*777@{3CX INTERNAL IP}:5060>
    15:42:18.525  [MS210000] C:7.1:Offer received. RTP connection: 192.168.2.7:40024(40025)
    15:42:18.523  Remote SDP is set for legC:7.1
    15:42:18.523  [CM505001]: Ext.20: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXPhone 6.0.20943.0] PBX contact: [sip:20@{3CX INTERNAL IP}:5060]
    15:42:18.513  [CM503001]: Call(7): Incoming call from Ext.20 to <sip:*777@{3CX INTERNAL IP}:5060>
    15:42:18.503  [CM500002]: Info on incoming INVITE:
      INVITE sip:*777@{3CX INTERNAL IP}:5060 SIP/2.0
      Via: SIP/2.0/UDP {SOFTPHONE IP}:64129;branch=z9hG4bK-d8754z-c20707349c788203-1---d8754z-;rport=64129
      Max-Forwards: 70
      Contact: <sip:20@{SOFTPHONE IP}:64129;rinstance=29b9df9ea7d3ad80>
      To: <sip:*777@{3CX INTERNAL IP}:5060>
      From: "Administrator"<sip:20@{3CX INTERNAL IP}:5060>;tag=21529161
      Call-ID: Mzg2NmVkNTllMGI1NWE3ZmZjODQzODdjODc1NGRmMWY.
      CSeq: 2 INVITE
      Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REGISTER, SUBSCRIBE, NOTIFY, REFER, INFO, MESSAGE
      Proxy-Authorization: Digest username="20",realm="3CXPhoneSystem",nonce="414d535c051e852a03:0c67dbb8b4dea80750c72dcf52182ab6",uri="sip:*777@{3CX INTERNAL IP}:5060",response="d5872a9cf876def3bc7b48018b4cb1d3",algorithm=MD5
      Supported: replaces
      User-Agent: 3CXPhone 6.0.20943.0
      Content-Length: 0
    
    If I had to guess, the line:
    15:42:18.525 [MS210000] C:7.1:Offer received. RTP connection: 192.168.2.7:40024(40025)
    seems like the culprit, but I'm unsure on what to do about it. I have no idea where 192.168.x.x is coming from. It is not a local network. I also don't understand why it is using ports in the 40,000 range. I have RTP configured in the 10000-10049 range (hard coded on my VoIP provider's side) in the Settings -> Network -> Ports tab.

    Any suggestions would be greatly appreciated.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Re: Yet Another "They Can Hear Me But I Can't Hear Them" thr

    Take a look at the IP on the machine from which you initiated the test with the softphone. The 192.168.2.7 is the address that 3CX belives initiated the call and is subsequently who 3CX is responding to. Is the softhone installed on the same machine where the 3CX system is running? is there possibly more than one NIC? Have you tried to ping the address to see if a response is there?
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    Re: Yet Another "They Can Hear Me But I Can't Hear Them" thr

    I was just going to say...what type of IP's do the sets have, pubic as well? 3CX isn't behind a router?
    Having private IP's on a log X'd out makes it difficult to troubleshoot and doesn't make a lot of sense security wise, the Public IP, yes.
     
  4. semose

    Joined:
    Jan 11, 2012
    Messages:
    7
    Likes Received:
    0
    Re: Yet Another "They Can Hear Me But I Can't Hear Them" thr

    Wow. Wasted on a good 6 hours on this. Turns out I had assigned a second IP address to my NIC, the 192.168.2.7 address, for testing purposes some time ago, and completely forgot about it. All the networks here at the office use 10.x.x.x addresses, so I completely discounted the possibility that the 192.168.x.x address was legitimate.

    All is now well, thanks for pushing me in the right direction, lneblett!
     
Thread Status:
Not open for further replies.