Microsoft 365 SSO stopped working with v18 update 7

Status
Not open for further replies.

paulsummers

Customer
Basic Certified
Joined
Feb 18, 2019
Messages
68
Reaction score
6
Self-hosted enterprise v18 update 7- following the update Microsoft SSO for both admin and web client has stopped working. Logged-in web client users are fine; new users and those that 'exit' the web client now receive a HTTP error 500, unable to handle this request on the URL https://*****.3cx.co.uk/webclient/signin/microsoft?jwt=true&ngsw-bypass

No change has been made to the Azure app or 3cx admin Microsoft 365 setting - and no obvious issue in logs/3CX admin.
 
Can you please check under the OS of the machine via SSH for a hidden folder called .dotnet found under /var/lib/3cxpbx/

You can use

cd /var/lib/3cxpbx/

Then issue the command.

 
Yes, I see a .dotnet folder.
 
Please delete the contents folder with the following command:

Ensure you have a full backup from the system downloaded to a safe location.

Then issue the following command:
rm -rf /var/lib/3cxpbx/.dotnet/corefx/cryptography/x509stores/ca/*

Then restart the machine and check if you can log in using the MS SSO.
 
This has resolved the issue, thanks.
 
  • Like
Reactions: Charles_3CX
You are welcome.
 
Status
Not open for further replies.