Can not provision new device

Status
Not open for further replies.

Vassilis Mitropoulos

Joined
Jun 6, 2018
Messages
19
Reaction score
0
Hi to all,

I have a serious problem. After the upgrade to v15.5 I can not provision a new device. When I connect a new device(Fanvil X3SP) in our network whatever I choose (add ext or assign ext) the phone never reboots as a result the provision never completes.
Before the upgrade(v14) with the same procedure I had made a lot of successful provisions.
I have looked at the IP blacklist and there is't any of this phones that I have added.
Please advice.
Thank you in advance.
 
When you factory reset a Fanvil phone the default time server values are "time.nist.gov" and "pool.ntp.org". If the phone cannot contact those either because they are blocked by the firewall or because the DNS is not resolving correctly then the phone cannot validate the validity of the certificate and provisioning will fail. If you use your own time server then you need to apply the settings into the phone and then try to provision.

Thank you. Yes, the environment is isolated, the IPs aren't NATed.
 
Hello mate,
I put the same time server in the PBX and the ip phone device but the device did not reboot after provision so the process isn't able to complete.
 
I put the same time server in the PBX and the ip phone device but the device did not reboot after provision so the process isn't able to complete.
I do not think you have the same issue as @ionut. Are you able to provision other devices or is the issue only with Fanvil devices?
 
I do not think you have the same issue as @ionut. Are you able to provision other devices or is the issue only with Fanvil devices?
I tried only with Fanvil. I don't have other devices.
 
Try it with a 3CX client and let us know if that is working. Download it and run it on a PC in the same network. Let the client start without configuration so it appears under the Phones tab as a new device. Try to assign that to an extension and see if that is working.
 
Try it with a 3CX client and let us know if that is working. Download it and run it on a PC in the same network. Let the client start without configuration so it appears under the Phones tab as a new device. Try to assign that to an extension and see if that is working.
Neither that way provision works
 
Neither that way provision works
Then i would suspect the reason the provisioning fails is different and not related to Fanvil devices. In this case like i mentioned before you will need to run a wireshark capture while trying to provision to see why it is failing.
What is the local IP range you are using? Also your provisioning link includes the local IP of FQDN?
 
Then i would suspect the reason the provisioning fails is different and not related to Fanvil devices. In this case like i mentioned before you will need to run a wireshark capture while trying to provision to see why it is failing.
What is the local IP range you are using? Also your provisioning link includes the local IP of FQDN?
The local ip range is 150.81.1.XXX and yes the provision link includes the local ip of FQDN.
I don't know if there is something must be changed in the nginx.cfg file
 
Last edited:
At the parameters and in the LOCALSUBNETS I have added the the local IP of our network. Also before the upgrade of our PBX provision works fine without this problem.
 
Status
Not open for further replies.

Forum statistics

Threads
112,094
Messages
590,718
Members
165,070
Latest member
QDS